gdebi Зависимость не выполняется

Я пытаюсь установить Skype на amd64 Kali-Linux после этого урока . Однако, как только я добрался до шага 4.1, gdebi skype-install.deb , я получил это сообщение об ошибке: This package is uninstallable Dependency is not satisfiable: libssl1.0.0 Я попытался apt-get install libssl1.0.0 и он сказал, что это был в курсе последних событий. Затем я попробовал apt-get autoremove а затем попытался apt-get install его снова. Он снова сказал, что это было актуально, и я снова попытался использовать gdebi безрезультатно. Любая помощь была бы потрясающей.

  • Микрофон Snowball больше не делится между приложениями
  • Как снизить трафик видеоизображения в виде скайпа?
  • Следить за всеми файлами, доступными для определенного процесса?
  • Trick для создания ограниченного пользователя linux. Я могу удаленно управлять независимо от того, где он подключается.
  • Веб-камера Skype перевернулась, но v4l1compat отсутствует
  • Альтернативы SkyPE, которые могут называть «настоящие» номера телефонов
  • Как предотвратить dwm при переключении тегов при запуске Skype
  • Установка Skype - debian amd64. Проблемы с libdbus
  • 3 Solutions collect form web for “gdebi Зависимость не выполняется”

    Пакет libssl1.0.0 больше не доступен в растяжке или сиде.

    Вы все равно можете получить его, загрузив его с сайта snapshot.debian.org: http://snapshot.debian.org/binary/libssl1.0.0/

    Имейте в виду, что обновления для этого пакета не будут установлены, если вы его устанавливаете таким образом.

    Отсутствующий пакет ( libssl1.0.0 ) не существует на Kali.repo , вы можете установить его из debian repo, как рекомендовано здесь .

     wget http://security.debian.org/debian-security/pool/updates/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u5_amd64.deb dpkg -i libssl1.0.0_1.0.1t-1+deb8u5_amd64.deb apt-get -f install 

    Затем установите skype:

     wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb dpkg --add-architecture i386 apt-get update gdebi skype-install.deb apt-get -f install 

    В моей системе Debian (неустойчивой) libssl1.0.0 также был недоступен, и я не мог получить его копию, как это было предложено в предыдущих ответах.

    Но я смог исправить пакет, требующий libssl1.0.2 вместо этого, который, как я заметил, был доступен мне, и Skype работал нормально.

    Это мой патч deb: http://teamfiles.n2.gs/3bbed19f40405b7d984d5d6113c461e7/skype_4.3.0.37-1_i386.deb

    Вы можете сделать это сами, как это:

     # This will create a skype/ directory. $ dpkg-deb -R skype-install.deb skype 

    Редактируйте skype/DEBIAN/control используя ваш предпочтительный текстовый редактор, и замените libssl1.0.0 на libssl1.0.2 (или аналогичную версию, доступную из вашего диспетчера пакетов, но, конечно, если версия слишком отличается, она, вероятно, не сработает).

     # This will create and install your patched package. $ dpkg-deb -b skype skype/ $ sudo gdebi '<path to generated deb>' 

    Надеюсь, это поможет.

    Linux и Unix - лучшая ОС в мире.