Установка gcc на rhel 6.1

GCC, похоже, не установлен на моей машине RHEL 6.1. Кроме того, когда я это сделал:

sudo yum install gcc 

Это забито:

 Updating Red Hat repositories. Setting up Install Process No package gcc available. Error: Nothing to do 

Эта же команда отлично работает на rhel 5.5. В чем может быть проблема?

 sudo yum search gcc 

Возвращает:

 libgcc.x86_64 : GCC version 4.4 shared support library libgomp.x86_64 : GCC OpenMP v3.0 shared support library sudo yum grouplist 

Возвращает:

 Loaded plugins: product-id, subscription-manager Updating Red Hat repositories. Setting up Group Process Error: No group data available for configured repositories sudo yum repolist 

Возвращает:

 Loaded plugins: product-id, subscription-manager Updating Red Hat repositories. repolist: 0 ls -l /etc/yum.repos.d/ 

Возвращает:

 -rw-r--r--. 1 root root 67 Nov 28 06:28 redhat.repo -rw-r--r--. 1 root root 529 Apr 27 2011 rhel-source.repo 

One Solution collect form web for “Установка gcc на rhel 6.1”

yum install gcc должен работать, как вы подозреваете. Возможно, вам нужно подписаться на определенный канал в RHN, но это gcc-рекомендация, похоже, указывает на то, что gcc должен быть доступен на всех этих каналах, и я предполагаю, что вы уже подписаны хотя бы на один из них:

  • Рабочий стол Red Hat Enterprise Linux (версия 6)
  • Red Hat Enterprise Linux HPC Node (версия 6)
  • Сервер Red Hat Enterprise Linux (версия 6)
  • Рабочая станция Red Hat Enterprise Linux (версия 6)
  • Можно ли отключить возможность установки из репозиториев yum, которые могут включать зависимости?
  • Как установить / обновить только определенный пакет в Fedora из репо?
  • Как установить gcc 6.4.1 на Fedora 26
  • YUM: обновление ключа GPG от репо
  • Невозможно установить что-либо с помощью yum в redhat 6.2
  • установить модуль python для конкретного экземпляра python
  • Отключить обновление репозитория в Fedora
  • Использует ли yum время сборки пакета, чтобы решить, является ли пакет более новым?
  • Добавление новых пакетов на сервер репозитория
  • Что означает предупреждение: rpmts_HdrFromFdno при установке из rpmfusion?
  • установка dsc30 - python 2.6 сражается назад
  • Установка Octave на CentOS - несовместимая ошибка библиотеки BLAS
  • Linux и Unix - лучшая ОС в мире.