FreeBSD 8.4 pkgdb выходит из строя после обновления до Ruby 1.9

Я просто обновляю Ruby 1.8 до Ruby 1.9. После обновления я выполнил инструкции в файле UPDATING, расположенном в /usr/ports . Я выпустил следующие две команды:

 portmaster -o lang/ruby19 lang/ruby18 portmaster -R -r ruby-1.9 

Когда я pkgdb я получаю следующую ошибку:

/usr/local/lib/ruby/1.9/rubygems/custom_require.rb:36:in `required не может загрузить такой файл – pkgtools (LoadError)

Не удалось ли восстановить систему до резервного копирования до обновления, может ли кто-нибудь предложить альтернативное решение?

Linux и Unix - лучшая ОС в мире.