Не удалось установить пакет FreeBSD

Я устанавливаю FreeBSD 12.0-CURRENT на новый рабочий стол.

Я потерял Wi-Fi соединение при обновлении системы.

После этого, пытаясь установить aterm с помощью команды:

 sudo pkg install aterm 

Я получил следующие ошибки:

 Proceed with this action [y/N]: y Fetching aterm-1.0.7.txz: 0% of 70 KiB pkg: cached package aterm-1.0.7: size mismatch, fetching from remote Fetching aterm-1.0.7: 0% of 70 KiB pkg: cached package aterm-1.0.7: size mismatch, cannot continue 

Я заметил, что он не работает при установке других пакетов.

Что делать?

One Solution collect form web for “Не удалось установить пакет FreeBSD”

Кажется, это некоторая коррупция в кеше пакетов.

Чтобы решить эту проблему, я сделал:

 sudo pkg clean sudo rm -rf /var/cache/pkg/* sudo pkg update -f 

После этого мне снова удалось установить пакеты.

Я основывался на этом потоке от форумов FreeBSD pkg 1.3.0: несоответствие размера не может продолжаться с аналогичной проблемой.

Linux и Unix - лучшая ОС в мире.