Intereting Posts
Изменен SSH-порт, не разрешив его через брандмауэр, заблокированный сейчас – что делать? grab git repo из нескольких источников в рецепте Yocto Могу ли я иметь собственную систему управления версиями? Легкий считыватель PDF, который может открывать несколько копий pdf с аннотациями и подсветкой OS X Yosemite сертифицирована по SUS – Single Unix Specification 3. Но какой стандарт posix он совместим? последний – 2008 год Существует ли идентификатор PID для каждого сервиса tomcat? Если он существует, можно ли найти имя службы из этого PID текущей службы tomcat? Копирование файла на несколько других файлов с разными именами ln -s $ SOURCE / * except – с помощью find? .screenrc, чтобы заставить уведомление о молчании оставаться Как изменить размер шрифта, количество строк / столбцов на терминале иметь / home / user / Downloads (и другие пользовательские папки) на другом разделе Почему это регулярное выражение perl не фиксирует обратную ссылку? Могу ли я объединить псевдоним bash? Возврат BASH к основной функции Как запустить последующие оболочки с правами root?

Не удается установить fail2ban на Centos 7.1

Я пытаюсь установить fail2ban на моем сервере centos 7.1

Я сделал:

yum install epel-release yum install fail2ban 

Но я получаю некоторые сообщения об ошибках:

  yum install epel-release Package epel-release-7-5.noarch already installed and latest version Nothing to do ----- [root@elliot ~]# yum install fail2ban Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * atomic: mirror1.34sp.com * base: centos.mirror.transip.nl * epel: ftp.nluug.nl * extras: centos.mirror.transip.nl * updates: centos.mirror.transip.nl Resolving Dependencies --> Running transaction check ---> Package fail2ban.noarch 0:0.9.2-1.el6 will be installed --> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.2-1.el6.noarch --> Processing Dependency: python-inotify for package: fail2ban-0.9.2-1.el6.noarch --> Processing Dependency: gamin-python for package: fail2ban-0.9.2-1.el6.noarch --> Running transaction check ---> Package fail2ban.noarch 0:0.9.2-1.el6 will be installed --> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.2-1.el6.noarch ---> Package gamin-python.x86_64 0:0.1.10-16.el7 will be installed --> Processing Dependency: gamin = 0.1.10-16.el7 for package: gamin-python-0.1.10-16.el7.x86_64 --> Processing Dependency: libgamin-1.so.0()(64bit) for package: gamin-python-0.1.10-16.el7.x86_64 ---> Package python-inotify.noarch 0:0.9.4-4.el7 will be installed --> Running transaction check ---> Package fail2ban.noarch 0:0.9.2-1.el6 will be installed --> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.2-1.el6.noarch ---> Package gamin.x86_64 0:0.1.10-16.el7 will be installed --> Finished Dependency Resolution Error: Package: fail2ban-0.9.2-1.el6.noarch (epel) Requires: python(abi) = 2.6 Installed: python-2.7.5-18.el7_1.1.x86_64 (@updates) python(abi) = 2.7 python(abi) = 2.7 Available: python-2.7.5-16.el7.x86_64 (base) python(abi) = 2.7 python(abi) = 2.7 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [root@elliot ~]# 

Может ли кто-нибудь помочь мне решить эту проблему? Я также попытался установить его на новый сервер, и у меня не было проблем на этом сервере

PS, если вы хотите, вы можете войти на мой компьютер

Похоже, что у вас могут быть установлены два epel-release – один для EPEL 6, один для EPEL 7. Ваша первая команда yum показывает, что установлен epel-release-7-5 , вторая команда yum вытягивает fail2ban-0.9.2-1.el6 который находится от EPEL 6 (не 7). Если это так, вы должны увидеть два результата из rpm -q epel-release . Если вы затем yum remove пакет выпуска EPEL 6 и выпустите yum clean all , вы должны после этого сможете yum install fail2ban успешно.