Intereting Posts
Почему «rm -rf ./» ничего не удаляет? менее в сочетании с последовательными цветовыми последовательностями предотвращает разрывы страниц LXDE: Как запустить программу / команду при нажатии одной или нескольких клавиш? Проблема с каталогом chown Могу ли я указать перенаправленный вход перед составной командой? «Emacs: стандартный ввод не является tty» при запуске Emacs при входе в систему Можете ли вы законно продавать модифицированные версии дистрибутивов Linux? Как rsync через ssh, когда имена каталогов имеют пробелы настроить exim для пересылки электронной почты системы (снаружи), на сервере с динамическим ip, за маршрутизатором DNS Маршрутизация iptables Apache открывает пользовательскую страницу в зависимости от ip Для чего нужны файлы pid и lock? Избегайте сбоя сети Ethernet, если кабель отключен Количество элементов в массиве bash, где имя массива является динамическим (т.е. хранится в переменной) Linux: Почему init и systemd используют так много операций ввода-вывода?

установка dsc30 – python 2.6 сражается назад

Я пытаюсь обновить некоторые системы до Cassandra 3.x. Установщик хочет Python (abi)> = 2.7, поэтому я его установил. Все еще видя эту ошибку:

Resolving Dependencies --> Running transaction check ---> Package dsc30.noarch 0:3.0.1-1 will be installed --> Processing Dependency: cassandra30 = 3.0.1 for package: dsc30-3.0.1-1.noarch --> Processing Dependency: python(abi) >= 2.7 for package: dsc30-3.0.1-1.noarch --> Running transaction check ---> Package cassandra30.noarch 0:3.0.1-1 will be installed --> Processing Dependency: python(abi) >= 2.7 for package: cassandra30-3.0.1-1.noarch ---> Package dsc30.noarch 0:3.0.1-1 will be installed --> Processing Dependency: python(abi) >= 2.7 for package: dsc30-3.0.1-1.noarch --> Finished Dependency Resolution Error: Package: dsc30-3.0.1-1.noarch (datastax) Requires: python(abi) >= 2.7 Installed: python-2.6.6-64.el6.x86_64 (@base-local) python(abi) = 2.6 Error: Package: cassandra30-3.0.1-1.noarch (datastax) Requires: python(abi) >= 2.7 Installed: python-2.6.6-64.el6.x86_64 (@base-local) python(abi) = 2.6 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest # python -V Python 2.7.11 

Чтение этой проблемы, по-видимому, возможно разбить yum, если python переводит свою версию (ы). Я бы предпочел не распутать это, поэтому я надеюсь, что кто-то здесь может показать мне пресловутый свет и объяснить, как установить этот бит.

CentOS 6.7


Редактировать:

Я установил python27, используя репозиторий SCL . Без изменений.

Вы можете использовать пакеты python27 из проекта IUS .

 $ repoquery --whatprovides 'python(abi) = 2.7' python27-0:2.7.11-1.ius.centos6.x86_64 

Эта версия python устанавливается параллельно с python на складе, поэтому yum и другие системные инструменты будут продолжать функционировать как обычно. Вы должны явно вызвать python2.7 , чтобы использовать более новую версию.

 $ python -V Python 2.6.6 $ python2 -V Python 2.6.6 $ python2.6 -V Python 2.6.6 $ python2.7 -V Python 2.7.11 

Использование python 2.7 из SCL работает для cassandra 3 … пока все настроено правильно.

  # Install all of the necessary packages $ yum install centos-release-SCL python27 cassandra30 # Tell SCL about the normally installed python2.7 packages $ echo "/usr/lib/python2.7/site-packages" | sudo tee /opt/rh/python27/root/usr/lib64/python2.7/site-packages/cqlshlib.pth # Set up a helpful alias for cqlsh to use the new python $ echo 'cqlsh() { scl enable python27 "cqlsh $@"; }' | sudo tee /etc/profile.d/cqlsh.sh 

Теперь вы можете использовать cqlsh, как обычно. Кроме того, поскольку python2.7 установлен с SCL, вы можете получить оболочку с ней в любое время с помощью:

 $ scl enable python27 bash 

Это должно решить проблемы с запуском cassandra 3.0.X и 3.X на CentOS 6, где python 2.6 требуется для работы yum.