Файл управления Debian «Обеспечивает» не удовлетворяет зависимости

USECASE

Пакет gnome-core зависит от gnome-shell-extensions >=3.14 . Я хотел бы удалить gnome-shell-extensions но чтобы удовлетворить зависимость, я должен заменить его фиктивным пакетом. Я использую equivs для этого, чтобы создать заменяющий фиктивный пакет для gnome-shell-extensions .

Мой файл управления equivs выглядит следующим образом:

  • Инструмент cmd в реальном времени, чтобы показать оставшееся место на жестком диске
  • Каким пользователям разрешено регистрироваться через SSH по умолчанию?
  • Недокументированный «chown user.» Сокращенный
  • Live-Build Debian пустой рабочий стол
  • Каков программный пакет для создания PDF-документов на ОС Debian и OpenBSD?
  • Установщик Debian упомянул, что неиспользуемые LVM VG и LV будут «отформатированы»,
  •  Section: misc Priority: optional Standards-Version: 3.9.2 Package: gnome-shell-extensions Version: 1.0 Maintainer: Me Myself <me@myself.org> Provides: gnome-shell-extensions Architecture: all Description: gnome-shell-extensions dummy package to satisfy gnome dependencies 

    вопрос

    Построенный пакет явно предоставляет gnome-shell-extensions , но даже после его установки apt все еще жалуется, что gnome-core : depends on: gnome-shell-extensions (>= 3.14)

    Я понимаю, что поле Version в управляющем файле не имеет к этому никакого отношения, поскольку оно только отмечает версию фиктивного пакета.

    Временное решение

    Я успешно сумел подделать исходный пакет, используя исходное имя пакета, то есть Package: gnome-shell-extensions , но я предпочел бы сохранить имя фиктивного пакета.

    Вопрос

    Что мне нужно сделать, чтобы удовлетворить зависимость gnome-shell-extensions >=3.14 при использовании другого пакета, который Provides: gnome-shell-extensions ?

  • Разрешение запрещено в скриптовой тюрьме chroot
  • Настройка debian ddclient с помощью dyndns noip.com
  • Назначение нескольких адресов IPv6 для одного интерфейса для веб-сервера https?
  • Как изменить таймаут в systemctl
  • Flash-плагин debian уязвим?
  • Отключить настройку громкости выше 100% в pulseaudio
  • One Solution collect form web for “Файл управления Debian «Обеспечивает» не удовлетворяет зависимости”

    Теперь вы должны иметь возможность использовать версию. Provides: ::

     Provides: gnome-shell-extensions (= 3.14.2-1) 

    Это поддерживается с dpkg 1.17.11, так что с Debian 8 (Jessie). Политика Debian не была обновлена, чтобы учитывать эту возможность, поэтому она по-прежнему претендует на две вещи, которые больше не верны:

    • Provides: не может быть ограничения версии;
    • отношения с ограничениями версии игнорируют виртуальные пакеты.

    Ошибка # 761219 отслеживает обновления документации.

    Linux и Unix - лучшая ОС в мире.