самый минимальный Debian / sid установлен с debootstrap?

В последние годы я использовал debootstrap для установки моего рабочего стола Debian (ежедневное использование), и я планирую использовать его еще раз, но до сих пор я просто использовал параметры debootstrap по умолчанию, на этот раз вместо этого я хотел бы установить минимальную систему.

Я сделал некоторые поиски, но до сих пор ничего не нашел, чего я еще не знал, большинство статей говорят, что они минимальны, но затем они просто используют параметры по умолчанию, вместо этого я хотел бы знать, есть ли exclude , чтобы обрезать их и все еще получать рабочая система.

  • Как изменить текстовый редактор по умолчанию в дистрибутиве Debian (сжатие)
  • Как сделать разделы системных файлов более крупными без переустановки
  • Некоторое программное обеспечение работает только от корневого терминала
  • LC_ALL: изменить язык нельзя
  • предотвращение dpkg-buildpackage с использованием / usr / bin в качестве места установки
  • Отправить и получить файлы через bluetoothctl на Debian jessie
  • Я планирую заглянуть в debootstrap, но подумал, чтобы спросить здесь раньше, может быть, кто-то уже знал или знал и может спасти меня некоторое время.

    редактировать

    Минимальный Debian состоит из пакетов с приоритетом и important

     dpkg-query -f '${binary:Package} ${Priority}\n' -W \ | grep -w 'required\|important' 

    Опция minbase все еще устанавливает некоторые extra , optional , standard , но очень немногие, в конечном итоге некоторые из них и некоторые important могут быть удалены (или вообще не установлены, я думаю, что --exclude должен работать, но не проверен)

    Под-скрипт оболочки deboostrap для sid – это /usr/share/debootstrap/scripts/sid , легко (резервное копирование и) настройка.

    После установки много места на диске извлекается из загруженного .deb , apt-get clean , apt-get autoclean должен освобождать некоторые.

    Некоторое пространство берется из локалей, docs, man-страниц, dpkg-reconfigure locales и пакета localepurge .

  • NetworkManager не может аутентифицироваться в WPA-EAP с использованием TTLS и PAP в LMDE
  • Разве что Debian stretch / sid является неустойчивой версией?
  • Как установить adobe reader-enu в 64-разрядный Debian 8.5?
  • Разделение раздела во время установки
  • Лунный свет в Debian
  • Cron сообщает об ошибке в php5-общем задании после обновления
  • One Solution collect form web for “самый минимальный Debian / sid установлен с debootstrap?”

    Я использую опцию --variant=minbase которая кажется довольно минимальной (около 150 МБ). Нет текстового редактора, но необходимые инструменты GNU, менеджер пакетов и сетевые функции с помощью iproute2.

    Linux и Unix - лучшая ОС в мире.