Debian Jessie: Почему gcc-4.7 конфликтует с gcc-4.8?

Мое последнее обновление до Jessie удалило gcc-4.7 из моей системы и установило gcc-4.8 на коробке. Проблема в том, что мне нужен первый.

Может ли кто-нибудь объяснить мне, почему эти две версии конфликтуют с Debian? Есть ли какая-то техническая причина, которая оправдывала бы это. Мой проект требует мучительного пути для компиляции gcc-4.8 ?

Есть ли безопасный способ установки gcc-4.7 параллельно с gcc-4.8 (компиляция не является вариантом – она ​​должна быть пакетом Debian)?

  • Ошибка компоновщика: / usr / bin / ld: не удается найти -lgcc_s
  • Каков самый быстрый способ установки GCC на Wind River 3.02?
  • MPICC с различными версиями GCC
  • Линейный выход литиевого выхода
  • Некоторые команды больше не отвечают?
  • gcc 4.6.3 локальная установка с gmp 5.0.5 mpfr 3.1.1 ошибки
  • Sparc Solaris - установить оптимизированный GCC 4.9, 32/64 бит?
  • Драйвер Debian Realtek RTL7832BS
  • One Solution collect form web for “Debian Jessie: Почему gcc-4.7 конфликтует с gcc-4.8?”

    gcc-4.7 не входит в Debian Jessie (см. https://bugs.debian.org/765379 ).

    Он все еще находится в Debian нестабильно и не конфликтует ни с чем. Поскольку Debian неустойчивый и Debian Jessie очень похожи на данный момент (ноябрь 2014), у вас не должно возникнуть никаких проблем.

    См. Например https://wiki.debian.org/AptPreferences или этот ответ, как устанавливать пакеты из unstable системы testing .

    Linux и Unix - лучшая ОС в мире.