Intereting Posts
Заполнение между выпадающими меню / панелями инструментов Что эквивалентно чистке Mac в Linux? Я хочу, чтобы grep из текстовой строки из многих файлов, как я могу запустить цикл для этого Почему установка wiki для мультимедиа прекращается? оболочка bash не появляется при запуске терминала Есть ли способ сделать apt-отчет, какие пакеты в dist-upgrade будут использовать дополнительное дисковое пространство? Драйвер Grub и Nvidia ведут себя по-разному, если включена поддержка Dell без UEFI (прежняя версия) Проверка наличия мобильного модема Dell Precision M4500 с Fedora 17 Есть ли инструмент Linux для дефрагментации разделов NTFS? Автозапуск приложения .desktop при запуске не работает Конфигурация Apache с прокси-сервером и местоположением Команда chmod для установки файла с правами отказа. apache httpd не может подключиться к Интернету Что именно происходит с моим пользователем jenkins? Arch Linux не отображается в загрузчике

Почему ./configure дает мне неудовлетворенные пакеты, которых не существует?

Я пытаюсь скомпилировать Caribou 0.4.18.1 на Xubuntu 14.04 .

В документе INSTALL говорится, что я должен запустить ./configure && make && make install .

Но шаг ./configure завершился:

 checking for python platform... linux2 checking for python script directory... ${prefix}/lib/python2.7/dist-packages checking for python extension module directory... ${exec_prefix}/lib/python2.7/dist-packages checking for CARIBOU... no configure: error: Package requirements ( pygobject-3.0 >= 2.90.3, gtk+-3.0 >= 3.0.0, clutter-1.0 >= 1.5.11, gdk-3.0 >= 3.0.0, x11, atspi-2 ) were not met: No package 'pygobject-3.0' found No package 'gtk+-3.0' found No package 'clutter-1.0' found No package 'gdk-3.0' found No package 'atspi-2' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables CARIBOU_CFLAGS and CARIBOU_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details. 

Попытка установить любой из этих пакетов не удалась, потому что они не входят в индекс пакета.

Я видел это с некоторыми другими программами, которые я хотел скомпилировать, так что это проблема с моей машиной.

Может ли кто-нибудь объяснить мне, что на самом деле говорит ошибка, и что я могу сделать против этого?

Зависимости выражаются не как имена пакетов, а как зависимости pkg-config . Я думаю, что в RPM-системах вы можете искать их напрямую, но в системах на базе Debian вам нужно искать соответствующие файлы.

Для этого самый простой способ – установить apt-file , обновить его индексы с помощью

 sudo apt-file update 

то вы можете использовать apt-file search с зависимостями. В твоем случае:

 apt-file search pygobject-3.0.pc apt-file search gtk+-3.0.pc 

и так далее. ( .pc файлы содержат информацию, необходимую для pkg-config .) Это скажет вам, что пакеты, которые вам нужно установить, являются соответственно python-gi-dev для pygobject-3.0 и libgtk-3-dev для gtk+-3.0 ; Я дам вам понять остальное.

Вы можете выполнить тот же поиск в Интернете, используя https://packages.debian.org (результаты, как правило, будут работать и на Xubuntu).

С небольшим количеством работы вы также можете использовать apt-cache search ;

 apt-cache search gtk+-3.0 | grep -- -dev 

должен содержать соответствующее название пакета (среди других возможно).

Как указано K1773L , так как caribou упакован в Xubuntu, вы можете запускать

 apt-get build-dep caribou 

для получения зависимостей сборки, но это даст зависимости от версии, которая была упакована; в общем случае, если у вас другое, вам могут понадобиться разные зависимости.

Поскольку caribou находится в репозиториях, вы можете просто запустить sudo apt-get build-dep caribou для установки всех зависимостей.