Как установить clang 3.9 или выше с помощью apt-get на Linux Mint?

Я знаю, что есть похожие вопросы для установки версий clang-lower. Но я пытаюсь следовать им, чтобы установить clang-3.9 или 4.0, но я не могу сделать это на своем Linux Mint 18.

Во-первых, я только получал варианты до clang-3.8, используя

sudo apt-get install clang 

после чего дважды нажмите вкладку.

Затем я последовал этой ссылке и следил за всем, что есть в первом ответе.

Теперь я вижу clang-3.9 и clang-4.0, когда я нажимаю вкладку после ввода sudo apt-get install clang .

Теперь, когда я это делаю

 sudo apt-get install clang-4.0 

Я получаю следующую ошибку:

  The following packages have unmet dependencies: clang-4.0 : Depends: libjsoncpp0 (>= 0.6.0~rc2) but it is not installable E: Unable to correct problems, you have held broken packages. 

Ваша версия Mint основана на Ubuntu 16.04, поэтому вы должны использовать источники для этого (как описано на главной странице репозитория ):

 deb http://apt.llvm.org/xenial/ llvm-toolchain-xenial main deb-src http://apt.llvm.org/xenial/ llvm-toolchain-xenial main # 3.8 deb http://apt.llvm.org/xenial/ llvm-toolchain-xenial-3.8 main deb-src http://apt.llvm.org/xenial/ llvm-toolchain-xenial-3.8 main # 3.9 deb http://apt.llvm.org/xenial/ llvm-toolchain-xenial-3.9 main deb-src http://apt.llvm.org/xenial/ llvm-toolchain-xenial-3.9 main 

Вам не нужно использовать ubuntu-toolchain-r/test PPA.