Intereting Posts
Почему необходимо скомпилировать все ядро ​​для простого патча? Как grep + показать только 7 последних измененных файлов? Общее использование ЦП и использование ЦП в списке процессов различаются в верхней реализации FreeBSD? Установка программного обеспечения без доступа пользователя root Используйте Lynx для загрузки источника страницы, на которой я сейчас нахожусь. Различия между% pre и% post в Kickstart на CentOS? Загрузочный загрузчик FreeBSD не загружается из правильного пула Как автоматизировать ktutil для немедленного перечисления записей keytab? Переменные среды Bash не устанавливаются bash + Есть ли что-то вроде log4j для скрипта bash? Моя система постоянно загружает и загружает с той же скоростью. Что это значит? odroid / ubuntu – запуск wlan Как надежно получить метку времени, в которой система загрузилась? найти каталоги, не содержащие файл Как заставить клавиши F1-F4 нормально вести себя в tmux

apt-get версия tmux устарела

Я использовал apt-get для установки tmux и после этого tmux -V возвратил 1.6, что является более старой версией. Согласно веб-сайту tmux , текущая версия – 2.2. Это проблема, потому что я хотел бы, чтобы команда z увеличила мое окно, которое находится только в версии 1.8 или новее.

Почему apt-get предоставляет такую ​​старую версию tmux? Нужно ли загружать и устанавливать 2.2 вручную для обновления моей версии или есть способ использовать apt-get для получения более поздней версии автоматически?

Различные версии Debian имеют разные версии tmux . Взгляните на страницу пакета для tmux . Кажется, что apt-get смотрит на хриплый (немного старый). Страница выпуска Debian показывает, сколько лет: 2013 (и все еще обновляется).

Кстати, вы можете запускать Ubuntu или какой-то другой дистрибутив downstream, а не Debian, но, скорее всего, будет такая же разница во времени.

Если вы используете стабилизацию Debian и у вас есть пакет, который хотите обновить, вы можете использовать backports, как показано на странице https://backports.debian.org/Instructions/

вкратце: добавьте «deb http://ftp.debian.org/debian jessie-backports main» (после main, также можно добавить Contrib и non-free, если вы их используете.) в ваш sources.list, который по умолчанию /etc/apt/sources.list

(с помощью root или с помощью sudo) с помощью apt-get update (или aptitude ). Затем, чтобы использовать пакет из backports, вам нужно использовать команду apt-get -t jessie-backports install / upgrade … (или склонность )

(При использовании Debian wheezy, также для него существуют резервные копии)