Intereting Posts
Как получить список компьютеров, похожих на то, что показано в разделе «Сеть» в Windows curl –data-urlencode и подчеркивания В чем разница между «перезапуском systemctl» и «systemctl start»? Могу ли я получить микросекундную зернистость, когда я рассчитываю количество наносекунд от Windows Epoch до сегодняшнего дня? Автоматические фоновые процессы Как вернуть направление для последнего ярлыка параметра? IP-таблицы / сетевые фильтры и модули Как получить семафоры и объекты sharedmem для определенного экземпляра apache, когда несколько экземпляров Apache запускаются с одним и тем же идентификатором приложения в ящике QEMU / KVM очень медленно Какая область интерфейса (глобальная или ссылка) используется? Сделать переключатель CapsLock между текстовым вводом и навигацией Дополнительные накладные расходы в цели MASQUERADE Как сохранить файл из аварийной оболочки initramfs? ошибка сегментации: передача-gtk & transmission-qt в linux mint Убедитесь, что на экране есть звонок / предупреждение со всей строкой состояния

Проблемы с обновлением apt-get

Я не могу выполнить apt-get upgrade по какой-либо причине на kali linux. Вот что происходит:

 root@kali:~# apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required: apg attr couchdb cups-pk-helper docutils-common docutils-doc dwarfdump erlang-asn1 erlang-base erlang-crypto erlang-eunit erlang-inets erlang-mnesia erlang-os-mon erlang-public-key erlang-runtime-tools erlang-snmp erlang-ssl erlang-syntax-tools erlang-tools erlang-webtool erlang-xmerl exif finger fonts-lyx freeglut3 freetds-common gir1.2-gnomekeyring-1.0 gir1.2-notify-0.7 gir1.2-vte-2.91 gnome-control-center-data gstreamer1.0-plugins-ugly ldap-utils libadns1 libavcodec56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat56 libavresample2 libavutil54 libboost-python1.58.0 libboost-python1.61.0 libcamel-1.2-54 libcdio-cdda1 libcdio-paranoia1 libcolord-gtk1 libcrypto++9v5 libct4 libdistorm3-3 libdvbpsi9 libemu2 libexpat1-dev libfreerdp-rail1.1 libgeos-3.5.0 libgeos-c1v5 libglade2-0 libgnome-keyring-common libgnome-keyring0 libgrilo-0.3-0 libgtksourceview2.0-0 libgtksourceview2.0-common libical1a libjavascriptcoregtk-1.0-0 libjs-excanvas libjs-jquery-form libjs-mochikit libjs-sphinxdoc libjs-underscore libladr4 liblapack3 libldb1 libmaxminddb0 libmozjs185-1.0 libnss-myhostname libopencore-amrnb0 libopencore-amrwb0 libpango1.0-0 libpcsc-perl libpff1 libpgm-5.1-0 libphonon4 libpostproc52 libpython-dev libpython2.7-dev libqscintilla2-12v5 libqscintilla2-l10n libqt4-declarative libqt4-designer libqt4-help libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-test libqtassistantclient4 librygel-core-2.6-2 librygel-db-2.6-2 librygel-renderer-2.6-2 librygel-server-2.6-2 libsidplay1v5 libswscale3 libsybdb5 libtevent0 libtidy-0.99-0 libtre5 libvncclient0 libvpx1 libvte-common libvte9 libwbclient0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebpdemux1 libwebpmux1 libx264-142 libzmq3 pcsc-tools phonon phonon-backend-vlc prover9 pulseaudio-module-bluetooth python-distorm3 python-fuse python-jdcal python-matplotlib-data python-mpltoolkits.basemap-data python-pastedeploy-tpl python-pip-whl python-pyexiv2-doc python-pylibemu python3-cups python3-cupshelpers python3-requests python3-urllib3 reglookup-doc rwho rwhod rygel samba-common smitools sqsh system-config-printer-common system-config-printer-udev tdb-tools texlive-latex-base texlive-latex-base-doc u3-tool volatility-tools x11-apps xclip zsh zsh-common Use 'apt autoremove' to remove them. The following packages have been kept back: vlc vlc-nox 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded. 1 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Traceback (most recent call last): File "/usr/bin/apt-listchanges", line 35, in <module> import ALCLog ImportError: No module named 'ALCLog' Setting up apt-listchanges (3.3) ... Traceback (most recent call last): File "/tmp/aptlcjmM9e0.py", line 6, in <module> import debconf ImportError: No module named 'debconf' dpkg: error processing package apt-listchanges (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: apt-listchanges E: Sub-process /usr/bin/dpkg returned an error code (1) 

Не уверен, что делать, теперь искал какое-то время, и я не могу его решить

По какой-то причине apt-listchanges не настроен должным образом; в результате он сбой при каждом запуске apt-get . Вы должны удалить его:

 dpkg --remove apt-listchanges 

Это должно позволить apt-get запускаться снова. Вы всегда можете попробовать снова установить apt-listchanges :

 apt-get install apt-listchanges