Установите apache2-mod-mono-2.10

Я пытаюсь установить mod-mono для apache, чтобы я мог запускать сайты C # asp.net с моего сервера. Проект, который у меня есть, – это проект .net 4.

Когда я вхожу в yast и выбираю apache2-mod-mono для установки, он говорит, что есть проблема, которая требует разрешения. Проблема в:

ничего не обеспечивает libc.so.6 (GLIC_2.11) (64 бит), требуемый для mono-core-2.10.1-32.1.x86_64

Яст предлагает решения:

  • не устанавливайте apache2-mod-mono
  • перерыв моноядерного, игнорируя некоторые из его зависимостей.

Я предполагаю, что если я выбираю break mono-core, разбивая его зависимости, что mono не будет работать правильно, так что это не решение.

Как мне обойти эту проблему.

Я запускаю openSUSE 11.2 (x86_64)

Проверьте эту тему askbuntu на /lib/libc.so.6 missing (?) . Может быть, здесь и здесь. Проверьте, где находится mono-core-2.10.1-32.1.x86_64 ища libc.so.6 и find , locate или что mono-core-2.10.1-32.1.x86_64 для libc.so.6.

Возможно, это уже на вашем компьютере, и вам просто нужно обновить ld.so.conf или создать символическую ссылку.

(Я предполагаю, что вы находитесь в системе x86_64)