Проблема с поврежденными пакетами

Мой os: Linux Mint 17.1 (x64) + Cinnamon

Я пытался сделать мои файлы wma для Linux, и я что-то сломал, потому что сейчас я не могу воспроизводить видео. Что я пробовал:

  • удаление папки ~/.gstreamer-1.0
  • sudo /usr/share/doc/libdvdread4/install-css.sh (может быть, это сломало мою систему?)
  • пытаясь установить некоторые библиотеки через apt-get (например, с libavcodec по имени и, возможно, с другими)

Теперь, когда я пытаюсь запустить mplayer, я получаю ошибку:

 > mplayer mplayer: error while loading shared libraries: libavcodec.so.54: cannot open shared object file: No such file or directory 

Другие игроки (vlc) тоже не работают. Поэтому я попробовал обновить свою систему. sudo apt-get update вывело некоторые ошибки:

 (...) Err http://ppa.launchpad.net trusty/main Sources 404 Not Found Get:21 http://packages.linuxmint.com rebecca/upstream i386 Packages [30,0 kB] Err http://ppa.launchpad.net trusty/main amd64 Packages 404 Not Found Hit http://archive.ubuntu.com trusty-updates/restricted Translation-en Err http://ppa.launchpad.net trusty/main i386 Packages 404 Not Found (...) W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/dists/trusty/main/source/Sources 404 Not Found W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found E: Some index files failed to download. They have been ignored, or old ones used instead. 

sudo apt-get upgrade не работает вообще:

 Reading package lists... Building dependency tree... Reading state information... You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: audacity : Depends: libavcodec54 (>= 6:9.1-1) but it is not installed or libavcodec-extra-54 (>= 6:9.13) but it is not installed ffmpeg : Depends: libavcodec54 (>= 7:1.2.5~) but it is not installed or libavcodec-extra-54 (>= 7:1.2.5~) but it is not installed gstreamer1.0-libav : Depends: libavcodec54 (>= 6:9.1-1) but it is not installed or libavcodec-extra-54 (>= 6:9.13) but it is not installed libavdevice53 : Depends: libavcodec54 (>= 7:1.2.5~) but it is not installed or libavcodec-extra-54 (>= 7:1.2.5~) but it is not installed libavfilter3 : Depends: libavcodec54 (>= 7:1.2.5~) but it is not installed or libavcodec-extra-54 (>= 7:1.2.5~) but it is not installed libavformat54 : Depends: libavcodec54 (>= 7:1.2.5~) but it is not installed or libavcodec-extra-54 (>= 7:1.2.5~) but it is not installed libchromaprint0 : Depends: libavcodec54 (>= 6:9.1-1) but it is not installed or libavcodec-extra-54 (>= 6:9.10) but it is not installed libopencv-highgui2.4 : Depends: libavcodec54 (>= 6:9.1-1) but it is not installed or libavcodec-extra-54 (>= 6:9.10) but it is not installed mencoder : Depends: libavcodec54 (>= 6:9.1-1) but it is not installed or libavcodec-extra-54 (>= 6:9.11) but it is not installed mplayer : Depends: libavcodec54 (>= 6:9.1-1) but it is not installed or libavcodec-extra-54 (>= 6:9.11) but it is not installed vlc-nox : Depends: libavcodec54 (>= 6:9.1-1) but it is not installed or libavcodec-extra-54 (>= 6:9.18) but it is not installed E: Unmet dependencies. Try using -f. 

то я попробовал sudo apt-get -f install :

 Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: folder-color-switcher gir1.2-nemo-3.0 nemo-emblems nemo-folder-color-switcher python-nemo python-psutil Use 'apt-get autoremove' to remove them. The following extra packages will be installed: libavcodec54 The following NEW packages will be installed: libavcodec54 0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded. Need to get 2715 kB of archives. After this operation, 7309 kB of additional disk space will be used. Do you want to continue? [Y/n] Y WARNING: The following packages cannot be authenticated! libavcodec54 Install these packages without verification? [y/N] y Err http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/ trusty/main libavcodec54 amd64 7:1.2.6-1~trusty1 404 Not Found E: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/pool/main/f/ffmpeg/libavcodec54_1.2.6-1~trusty1_amd64.deb 404 Not Found E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? 

Затем я запускаю sudo apt-get update --fix-missing который дал мне подобные ошибки для sudo apt-get update .
Я также попробовал синаптический пакет менеджер, который во время старта заявил: «У вас есть 11 сломанных пакетов в вашей системе! …». Я попробовал Edit => Fix Broken Packages который, казалось, ничего не делал (даже не выдавал ошибку). Затем я выбрал «Фильтр зависимых зависимостей», пометил все пакеты там для переустановки, и после нескольких экранов я получил ошибки:

 W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/pool/main/f/ffmpeg/libavcodec54_1.2.6-1~trusty1_amd64.deb 404 Not Found W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/pool/main/f/ffmpeg/ffmpeg_1.2.6-1~trusty1_amd64.deb 404 Not Found W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/pool/main/f/ffmpeg/libavdevice53_1.2.6-1~trusty1_amd64.deb 404 Not Found W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/pool/main/f/ffmpeg/libavfilter3_1.2.6-1~trusty1_amd64.deb 404 Not Found W: Failed to fetch http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/pool/main/f/ffmpeg/libavformat54_1.2.6-1~trusty1_amd64.deb 404 Not Found 

Итак, кто-нибудь знает, что / как я сломался, и как я могу это исправить? Спасибо.

  • Включая Linux Mint при продаже оборудования?
  • Случайные ошибки с интерфейсом ethernet наводнение системного журнала
  • Software Source перестает работать при изменении имени выпуска в файле lsb_release
  • Как сделать зеркало репозитория пакетов Mint Linux с debmirror?
  • Linux Mint: как обновлять ссылки репозитория
  • Linux Mint прекратил загрузку
  • Linux Mint - отображение масштабирования с использованием нескольких экранов
  • Ярлык для «Показать все окна»
  • 2 Solutions collect form web for “Проблема с поврежденными пакетами”

    Я исправил это следующим образом:

    • Откройте «Источники программного обеспечения»
    • В закладке PPA найдите записи с именем «ffmpeg» и удалите их все
    • Затем выполните эти команды в терминале (они обновляют / очищают всю систему. Если вы не хотите обновлять дистрибутив, вы можете опустить строку с частью dist-upgrade ): sudo apt-get -f install sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade sudo apt-get autoremove sudo apt-get autoclean sudo apt-get clean

    • По желанию установить mplayer и / или vlc для воспроизведения видео / аудио файлов: sudo apt-get install mplayer sudo apt-get install vlc

    и все работает как обычно.

    Легче (если у вас есть Synaptic)

    • Откройте терминал и запустите sudo synaptic
    • В Synaptic выберите «Настройки»> «Хранилища»
    • Найдите репозитории, которые дают вам ошибки.

      Здесь вы можете «отключить» или выбрать и удалить. Когда вы закончите с репозиториями, обязательно нажмите OK и пусть Synaptic сделает свой трюк.

    • Выйти из Synaptic и подтвердить

      Нажмите «ctrl + Q» и убедитесь, что вы завершите работу Synaptic, а не просто скомбинируйте его, иначе apt-get вернется к ошибке использования.

    • Откройте терминал и запустите sudo apt-get update

    И вот он у вас есть, больше никаких ошибок 🙂

    Надеюсь, это понятно, только Linux используется на неделю.

    Linux и Unix - лучшая ОС в мире.