Отключить зависимости от сбоя обновления zypper

Для основного RPM требуется определенная версия зависимостей, например:

  • main-1.0.0 требует foo-1.0.0 , bar-1.0.0
  • main-1.1.0 требует foo-1.1.0 , bar-1.1.0

Когда я пытаюсь обновить основной RPM, во время обновления зависимостей есть ошибка.

 main-1.0.0 <-- not updated, because error updating dependencies foo-1.1.0 <-- updated successfully bar-1.0.0 <-- update failed 

Как я могу использовать откатные зависимости ( foo – это пример)?

Я попытался принудительно установить исходную версию основного RPM, но он отказался, поскольку версия уже установлена.

 zypper in -f main-1.0.0 

Поддерживает ли zypper или rpm откат в этой ситуации? Мне не нравится ручное понижение зависимостей один за другим, и я не знаю, в какой версии они должны быть.

Interesting Posts

Связь между дистрибутором и менеджером пакетов

Как я могу создать свой собственный файл орфографии для vim?

Различные MD5Sum для одного и того же файла в том же каталоге

Почему «процесс backporting не учитывает выпуски в потоке»?

Почему 8 чисел считаются «сильным» паролем?

lsusb частично не работает, проблема с шиной USB или с командой?

/ bin / sh: определение функции импорта ошибок для `module '

Подключения к серверу мониторинга – проблема форматирования Netstat

Установка типа файла vim с помощью модели не работает должным образом

как написать зависимость запуска от доступности Интернета?

Как я могу изменить логин при аутентификации на SSH?

Почему «{}» и «%» обычно используются как переменные в xargs?

Как разделить доступ Wi-Fi через hotspot (например, fon) через мою сеть ethernet?

Как grep для нескольких шаблонов на нескольких строках?

Могу ли я предотвратить замедление zsh с большой историей?

Linux и Unix - лучшая ОС в мире.