Intereting Posts
Быстрый и малый C ++ https proxy Невозможно установить virt во время кикстарта гипервизора Изменить файл в / etc с помощью сценариев оболочки? Разделение дисков LVM отсутствует Предотвратить автозаполнение пути от использования CDPATH в bash? Как служба с PrivateTmp = true получает доступ к сокету unix в каталоге / tmp (например, для отправки заданий Torque из PHP, работающего в Apache) В чем разница между «–color = auto» и «–color = tty»? USB-устройство Ethernet не работает в VM fail2ban терпит неудачу 2 запрещает попытки входа в систему к серверу smtp (postfix) в контейнере dockerа Установка docker зависает при настройке докер-двигателя на ubuntu xenial Будет ли Docky работать на gnome 3 с помощью оболочки gnome? Найти файлы gif / jpeg с расширением png и преобразовать в png В чем смысл «stat» в сообщении об ошибке SFTP «Не удалось установить удаленный файл», Как разбить логи varnishncsa на отдельные под systemd (Ubuntu 16.04) искажение ext4 найдено в суперблоке, но файловая система может быть смонтирована

Неудачное изменение зависимостей для растягивания

Я просто пытался обновить свою систему от Debian Jessie, чтобы растянуться. Сначала я изменил /etc/apt/sources.list на:

 deb http://security.debian.org/ stretch/updates main deb-src http://security.debian.org/ stretch/updates main deb http://ftp.debian.org/debian/ stretch main contrib non-free deb-src http://ftp.debian.org/debian/ stretch main contrib non-free 

Затем я запустил apt-get update && apt-get upgrade && apt-get dist-upgrade . Теперь у меня большой беспорядок с неудовлетворенными зависимостями:

 a@b ~ % sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: aptitude : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable calibre-bin : Depends: libicu57 (>= 57.1-1~) but it is not installed Recommends: calibre (>= 2.75.1+dfsg-1) but 2.5.0+dfsg-1 is installed djvulibre-bin : Depends: libdjvulibre21 (= 3.5.25.4-4+b1) but 3.5.27.1-7 is installed easytag : Depends: libtag1c2a (>= 1.9.1) but it is not installable evolution : Depends: evolution-data-server (< 3.13) but 3.22.7-1 is installed evolution-data-server : Depends: libebook-1.2-16 (>= 3.17) but it is not installed Depends: libebook-contacts-1.2-2 (>= 3.16.2) but it is not installed Depends: libedataserver-1.2-22 (>= 3.21.92) but it is not installed Depends: libicu57 (>= 57.1-1~) but it is not installed Depends: evolution-data-server-common (= 3.22.7-1) but 3.12.9~git20141128.5242b0-2+deb8u3 is installed gedit : Depends: libgtk-3-0 (>= 3.21.4) but 3.14.5-1+deb8u1 is installed gir1.2-webkit2-4.0 : Depends: libwebkit2gtk-4.0-37 (>= 2.13.91) but it is not installed gnome-online-accounts : Depends: libwebkit2gtk-4.0-37 (>= 2.8.1) but it is not installed gnome-online-miners : Depends: grilo-plugins-0.3 but it is not installed gnome-system-monitor : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable gparted : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable gstreamer1.0-plugins-bad : Depends: libgtk-3-0 (>= 3.16.2) but 3.14.5-1+deb8u1 is installed gvfs : Depends: gvfs-daemons (< 1.22.2-1.1~) Depends: gvfs-libs (= 1.22.2-1) but 1.30.4-1 is installed Depends: gvfs-common (= 1.22.2-1) but 1.30.4-1 is installed gvfs-backends : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed Depends: gvfs (= 1.30.4-1) but 1.22.2-1 is installed gvfs-bin : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed gvfs-daemons : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed gvfs-libs : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed imagescan : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable inkscape : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libatkmm-1.6-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libavfilter5 : Depends: libopencv-core2.4 but it is not installable Depends: libopencv-imgproc2.4 but it is not installable libboost-date-time1.55-dev : Depends: libboost-date-time1.55.0 (= 1.55.0+dfsg-3) but it is not installable libcairomm-1.0-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libcamel-1.2-59 : Depends: libicu57 (>= 57.1-1~) but it is not installed libclutter-1.0-0 : Depends: libgtk-3-0 (>= 3.16.2) but 3.14.5-1+deb8u1 is installed libclutter-gtk-1.0-0 : Depends: libgtk-3-0 (>= 3.21.0) but 3.14.5-1+deb8u1 is installed libcmis-0.4-4 : Depends: libboost-date-time1.55.0 but it is not installable libcpan-meta-perl : Depends: perl (>= 5.21.5) but 5.20.2-3+deb8u7 is installed or libjson-pp-perl (>= 2.27300) libcwidget3 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libebackend-1.2-10 : Depends: libedataserver-1.2-22 (>= 3.21.90) but it is not installed libecal-1.2-19 : Depends: libedataserver-1.2-22 (>= 3.17) but it is not installed libedata-book-1.2-25 : Depends: libebook-contacts-1.2-2 (>= 3.16.2) but it is not installed Depends: libedataserver-1.2-22 (>= 3.21.90) but it is not installed libedata-cal-1.2-28 : Depends: libedataserver-1.2-22 (>= 3.21.90) but it is not installed libfarstream-0.1-0 : Depends: gstreamer0.10-plugins-good (>= 0.10.29) but it is not installable libgdal1h : Depends: libdapserver7 but it is not installable libgirepository-1.0-1 : Depends: libglib2.0-0 (>= 2.50.0) but 2.48.0-1~bpo8+1 is installed libglibmm-2.4-1c2a : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libgoa-backend-1.0-1 : Depends: libgtk-3-0 (>= 3.19.12) but 3.14.5-1+deb8u1 is installed Depends: libwebkit2gtk-4.0-37 (>= 2.8.1) but it is not installed libgtkmm-2.4-1c2a : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libgtkmm-3.0-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libgtksourceview-3.0-1 : Depends: libgtk-3-0 (>= 3.19.12) but 3.14.5-1+deb8u1 is installed libical2 : Depends: libicu57 (>= 57.1-1~) but it is not installed libjavascriptcoregtk-4.0-18 : Depends: libicu57 (>= 57.1-1~) but it is not installed libnautilus-extension1a : Depends: libglib2.0-0 (>= 2.49.1) but 2.48.0-1~bpo8+1 is installed libopenmpi-dev : Depends: libopenmpi1.6 (= 1.6.5-9.1+deb8u1) but it is not installable libpangomm-1.4-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libphonenumber6 : Depends: libboost-date-time1.55.0 but it is not installable libqt5core5a : Depends: libicu57 (>= 57.1-1~) but it is not installed libqt5webkit5 : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-calc : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-core : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-draw : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-evolution : Depends: libebook-1.2-16 but it is not installed libreoffice-gtk2 : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-writer : Depends: libicu57 (>= 57.1-1~) but it is not installed librhythmbox-core10 : Depends: libgtk-3-0 (>= 3.16.2) but 3.14.5-1+deb8u1 is installed libscotch-5.1 : Depends: libopenmpi1.6 but it is not installable libsoprano4 : Depends: libclucene-core1 (>= 2.3.3.4) but it is not installable libtag1v5-vanilla : Depends: libicu57 (>= 57.1-1~) but it is not installed libtotem0 : Depends: libgnome-desktop-3-12 (>= 3.17.92) but it is not installed Depends: libgtk-3-0 (>= 3.19.4) but 3.14.5-1+deb8u1 is installed libvtk5.8 : Depends: libopenmpi1.6 but it is not installable libvtk6.1 : Depends: libopenmpi1.6 but it is not installable libxml++2.6-2 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable lightspark-common : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable open-vm-tools-desktop : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable openmpi-bin : Depends: libopenmpi1.6 but it is not installable paraview : Depends: libopenmpi1.6 but it is not installable pavucontrol : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable perl-doc : Depends: perl (>= 5.24.1-1) but 5.20.2-3+deb8u7 is installed python-vtk6 : Depends: libopenmpi1.6 but it is not installable python3 : Depends: python3-minimal (= 3.4.2-2) but 3.5.3-1 is installed Depends: libpython3-stdlib (= 3.4.2-2) but 3.5.3-1 is installed python3-apt : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-brlapi : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-cairo : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-dbus : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-dev : Depends: python3 (= 3.5.3-1) but 3.4.2-2 is installed python3-gi-cairo : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed Depends: python3-gi (= 3.22.0-2) but 3.14.0-1 is installed python3-markupsafe : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-pil : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-pyqt5 : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-pyqt5.qtwebkit : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-sip : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-uno : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-yaml : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed rhythmbox : Depends: rhythmbox-data (= 3.1-1) but 3.4.1-2 is installed rhythmbox-plugins : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed Depends: rhythmbox (= 3.4.1-2+b1) but 3.1-1 is installed spamassassin : Depends: libmail-dkim-perl but it is not installed texlive-binaries : Depends: libptexenc1 (< 2014.20140926.35254-6.1~) but 2016.20160513.41080.dfsg-2 is installed Depends: libkpathsea6 (< 2014.20140926.35254-6.1~) but 2016.20160513.41080.dfsg-2 is installed totem : Depends: libtotem0 (< 3.15) but 3.22.1-1 is installed Depends: totem-common (= 3.14.0-2) but 3.22.1-1 is installed totem-plugins : Depends: libgtk-3-0 (>= 3.19.4) but 3.14.5-1+deb8u1 is installed Depends: totem (= 3.22.1-1) but 3.14.0-2 is installed vlc-nox : Depends: libtag1c2a (>= 1.9.1) but it is not installable E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). 

Если я запустил apt --fix-broken install проблема не исчезнет:

 a@b ~ % sudo apt --fix-broken install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... failed. The following packages have unmet dependencies: aptitude : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable calibre-bin : Depends: libicu57 (>= 57.1-1~) but it is not installed Recommends: calibre (>= 2.75.1+dfsg-1) but 2.5.0+dfsg-1 is installed [The same as in the upper error log] totem : Depends: libtotem0 (< 3.15) but 3.22.1-1 is installed Depends: totem-common (= 3.14.0-2) but 3.22.1-1 is installed totem-plugins : Depends: libgtk-3-0 (>= 3.19.4) but 3.14.5-1+deb8u1 is installed Depends: totem (= 3.22.1-1) but 3.14.0-2 is installed vlc-nox : Depends: libtag1c2a (>= 1.9.1) but it is not installable E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies 

Выход apt-get dist-upgrade :

 a@b ~ % sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: aptitude : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable calibre-bin : Depends: libicu57 (>= 57.1-1~) but it is not installed Recommends: calibre (>= 2.75.1+dfsg-1) but 2.5.0+dfsg-1 is installed djvulibre-bin : Depends: libdjvulibre21 (= 3.5.25.4-4+b1) but 3.5.27.1-7 is installed easytag : Depends: libtag1c2a (>= 1.9.1) but it is not installable evolution : Depends: evolution-data-server (< 3.13) but 3.22.7-1 is installed evolution-data-server : Depends: libebook-1.2-16 (>= 3.17) but it is not installed Depends: libebook-contacts-1.2-2 (>= 3.16.2) but it is not installed Depends: libedataserver-1.2-22 (>= 3.21.92) but it is not installed Depends: libicu57 (>= 57.1-1~) but it is not installed Depends: evolution-data-server-common (= 3.22.7-1) but 3.12.9~git20141128.5242b0-2+deb8u3 is installed gedit : Depends: libgtk-3-0 (>= 3.21.4) but 3.14.5-1+deb8u1 is installed gir1.2-webkit2-4.0 : Depends: libwebkit2gtk-4.0-37 (>= 2.13.91) but it is not installed gnome-online-accounts : Depends: libwebkit2gtk-4.0-37 (>= 2.8.1) but it is not installed gnome-online-miners : Depends: grilo-plugins-0.3 but it is not installed gnome-system-monitor : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable gparted : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable gstreamer1.0-plugins-bad : Depends: libgtk-3-0 (>= 3.16.2) but 3.14.5-1+deb8u1 is installed gvfs : Depends: gvfs-daemons (< 1.22.2-1.1~) Depends: gvfs-libs (= 1.22.2-1) but 1.30.4-1 is installed Depends: gvfs-common (= 1.22.2-1) but 1.30.4-1 is installed gvfs-backends : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed Depends: gvfs (= 1.30.4-1) but 1.22.2-1 is installed gvfs-bin : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed gvfs-daemons : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed gvfs-libs : Depends: libglib2.0-0 (>= 2.49.3) but 2.48.0-1~bpo8+1 is installed imagescan : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable inkscape : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libatkmm-1.6-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libavfilter5 : Depends: libopencv-core2.4 but it is not installable Depends: libopencv-imgproc2.4 but it is not installable libboost-date-time1.55-dev : Depends: libboost-date-time1.55.0 (= 1.55.0+dfsg-3) but it is not installable libcairomm-1.0-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libcamel-1.2-59 : Depends: libicu57 (>= 57.1-1~) but it is not installed libclutter-1.0-0 : Depends: libgtk-3-0 (>= 3.16.2) but 3.14.5-1+deb8u1 is installed libclutter-gtk-1.0-0 : Depends: libgtk-3-0 (>= 3.21.0) but 3.14.5-1+deb8u1 is installed libcmis-0.4-4 : Depends: libboost-date-time1.55.0 but it is not installable libcpan-meta-perl : Depends: perl (>= 5.21.5) but 5.20.2-3+deb8u7 is installed or libjson-pp-perl (>= 2.27300) libcwidget3 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libebackend-1.2-10 : Depends: libedataserver-1.2-22 (>= 3.21.90) but it is not installed libecal-1.2-19 : Depends: libedataserver-1.2-22 (>= 3.17) but it is not installed libedata-book-1.2-25 : Depends: libebook-contacts-1.2-2 (>= 3.16.2) but it is not installed Depends: libedataserver-1.2-22 (>= 3.21.90) but it is not installed libedata-cal-1.2-28 : Depends: libedataserver-1.2-22 (>= 3.21.90) but it is not installed libfarstream-0.1-0 : Depends: gstreamer0.10-plugins-good (>= 0.10.29) but it is not installable libgdal1h : Depends: libdapserver7 but it is not installable libgirepository-1.0-1 : Depends: libglib2.0-0 (>= 2.50.0) but 2.48.0-1~bpo8+1 is installed libglibmm-2.4-1c2a : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libgoa-backend-1.0-1 : Depends: libgtk-3-0 (>= 3.19.12) but 3.14.5-1+deb8u1 is installed Depends: libwebkit2gtk-4.0-37 (>= 2.8.1) but it is not installed libgtkmm-2.4-1c2a : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libgtkmm-3.0-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libgtksourceview-3.0-1 : Depends: libgtk-3-0 (>= 3.19.12) but 3.14.5-1+deb8u1 is installed libical2 : Depends: libicu57 (>= 57.1-1~) but it is not installed libjavascriptcoregtk-4.0-18 : Depends: libicu57 (>= 57.1-1~) but it is not installed libnautilus-extension1a : Depends: libglib2.0-0 (>= 2.49.1) but 2.48.0-1~bpo8+1 is installed libopenmpi-dev : Depends: libopenmpi1.6 (= 1.6.5-9.1+deb8u1) but it is not installable libpangomm-1.4-1 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable libphonenumber6 : Depends: libboost-date-time1.55.0 but it is not installable libqt5core5a : Depends: libicu57 (>= 57.1-1~) but it is not installed libqt5webkit5 : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-calc : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-core : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-draw : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-evolution : Depends: libebook-1.2-16 but it is not installed libreoffice-gtk2 : Depends: libicu57 (>= 57.1-1~) but it is not installed libreoffice-writer : Depends: libicu57 (>= 57.1-1~) but it is not installed librhythmbox-core10 : Depends: libgtk-3-0 (>= 3.16.2) but 3.14.5-1+deb8u1 is installed libscotch-5.1 : Depends: libopenmpi1.6 but it is not installable libsoprano4 : Depends: libclucene-core1 (>= 2.3.3.4) but it is not installable libtag1v5-vanilla : Depends: libicu57 (>= 57.1-1~) but it is not installed libtotem0 : Depends: libgnome-desktop-3-12 (>= 3.17.92) but it is not installed Depends: libgtk-3-0 (>= 3.19.4) but 3.14.5-1+deb8u1 is installed libvtk5.8 : Depends: libopenmpi1.6 but it is not installable libvtk6.1 : Depends: libopenmpi1.6 but it is not installable libxml++2.6-2 : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable lightspark-common : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable open-vm-tools-desktop : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable openmpi-bin : Depends: libopenmpi1.6 but it is not installable paraview : Depends: libopenmpi1.6 but it is not installable pavucontrol : Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable perl-doc : Depends: perl (>= 5.24.1-1) but 5.20.2-3+deb8u7 is installed python-vtk6 : Depends: libopenmpi1.6 but it is not installable python3 : Depends: python3-minimal (= 3.4.2-2) but 3.5.3-1 is installed Depends: libpython3-stdlib (= 3.4.2-2) but 3.5.3-1 is installed python3-apt : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-brlapi : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-cairo : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-dbus : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-dev : Depends: python3 (= 3.5.3-1) but 3.4.2-2 is installed python3-gi-cairo : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed Depends: python3-gi (= 3.22.0-2) but 3.14.0-1 is installed python3-markupsafe : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-pil : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-pyqt5 : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-pyqt5.qtwebkit : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-sip : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-uno : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed python3-yaml : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed rhythmbox : Depends: rhythmbox-data (= 3.1-1) but 3.4.1-2 is installed rhythmbox-plugins : Depends: python3 (>= 3.5~) but 3.4.2-2 is installed Depends: rhythmbox (= 3.4.1-2+b1) but 3.1-1 is installed spamassassin : Depends: libmail-dkim-perl but it is not installed texlive-binaries : Depends: libptexenc1 (< 2014.20140926.35254-6.1~) but 2016.20160513.41080.dfsg-2 is installed Depends: libkpathsea6 (< 2014.20140926.35254-6.1~) but 2016.20160513.41080.dfsg-2 is installed totem : Depends: libtotem0 (< 3.15) but 3.22.1-1 is installed Depends: totem-common (= 3.14.0-2) but 3.22.1-1 is installed totem-plugins : Depends: libgtk-3-0 (>= 3.19.4) but 3.14.5-1+deb8u1 is installed Depends: totem (= 3.22.1-1) but 3.14.0-2 is installed vlc-nox : Depends: libtag1c2a (>= 1.9.1) but it is not installable E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). 

Каким образом это исправить?

Я проследил проблему до ручной установки python3.5 .

После удаления вручную ( rm -r /usr/local/python* ), как описано в этой ошибке , dist-upgrade получился хорошо.