Решение круговой зависимости ад для libX11 и libXi

Я пытаюсь установить X11 из источника.

Исходные файлы из некоторого репозитория :

 libX11-1.6.0.tar.gz libXi-1.7.1.901.tar.gz 

libX11-1.6.0

 paulk@node005:libX11-1.6.0$ ./configure --prefix=$HOME/software XKBExtDev.c:35:31: fatal error: X11/extensions/XI.h: No such file or directory compilation terminated. make[3]: *** [XKBExtDev.lo] Error 1 make[3]: Leaving directory `/home/paulk/libX11-1.6.0/src/xkb' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory `/home/paulk/libX11-1.6.0/src' make[1]: *** [all] Error 2 make[1]: Leaving directory `/home/paulk/libX11-1.6.0/src' make: *** [all-recursive] Error 1 

но для libXi-1.7.1.901

 paulk@node005:libXi-1.7.1.901$ configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.4.99.1 xextproto >= 7.0.3 xext >= 1.0.99.1 inputproto >= 2.2.99.1) were not met: No package 'x11' found No package 'xext' found No package 'inputproto' found 

Что я могу пропустить?

Если вы строите исходные источники X.Org, X11/extensions/XI.h происходит из пакета inputproto , а не самого libXi.

Вы можете увидеть его в браузере git по адресу http://cgit.freedesktop.org/xorg/proto/inputproto/tree/ .