Intereting Posts
Почему Ctrl-C ведет себя иначе, чем kill -2 Можно ли восстановить файлы после некорректного отключения? Проблема с сетью с Virtualbox Обмен переменными в нескольких сценариях оболочки Gentoo Linux GPG правильно шифрует файл, прошедший через параметр, но при чтении со стандартного ввода выбрасывает «Несоответствующий ioctl для устройства» Можно ли получить «старую» временную марку? Как добавить разрешения `cap_sys_admin` для пользователя в CentOS 7? Ошибка OpenLDAP при добавлении ACL Самый маленький дистрибутив Linux для PPTP VPN-сервера (poptop)? Не удается переслать X11 больше с сервера ssh Использует ли Gnome Shell Mutter? Предотвратите использование Iceweasel, чтобы сайты могли переопределять ярлыки по умолчанию как надежно определять процессы, используя файлы после `umount -l` на linux Загрузите все страницы, которые были связаны на странице в определенном регионе. Ошибка после установки dnf на CentOS 7

Невозможно установить композитор на FreeBSD 10

У меня есть FAMP SERVER, который я настраиваю.

  1. FreeBSD 10.1
  2. Apache 2.4
  3. MySQL 5.6
  4. Php 5.6

До сих пор все работает нормально. Я установил symfony без проблем, но теперь пытаюсь установить композитор.

curl -sS https://getcomposer.org/installer | php 

Я получаю следующий вывод (см. Ниже), но я не знаю, как исправить проблему.

Пробный просмотр Php.ini и файла make на mod_php56 в usr / ports.


 #!/usr/bin/env php 

Некоторые настройки на вашем компьютере не позволяют работать с Composer. Убедитесь, что вы устранили перечисленные ниже проблемы и снова запустите этот скрипт:

Расширение json отсутствует. Установите его или перекомпилируйте php без –disable-json

Расширение phar отсутствует. Установите его или перекомпилируйте php без –disable-phar

Расширение фильтра отсутствует. Установите его или перекомпилируйте php без –disable-filter

Расширение хеша отсутствует. Установите его или перекомпилируйте php без –disable-hash

Расширение openssl отсутствует, что означает, что безопасные передачи HTTPS невозможны. Если возможно, вы должны включить его или перекомпилировать php с кодом –with-openssl здесь

Хорошо, я понял это

Мне нужно было запустить pkg install php56- [имя модуля missng] -5.6.9 Для каждого из вышеперечисленных модулей (на самом деле хэш пришел с одним из других)

Я также запускал pkg install OpenSSL, но я не уверен, нужно ли мне это делать или нет.