Потерянный звук колонок после отсоединения наушников

Вчера я экспериментировал с действительно странным поведением на моем Thinkpad.

После работы с LMMS (музыкальной программой) с наушниками я выключил ноутбук и отключил их.

В следующий раз, когда я включил его, я понял, что звука вообще нет: ни в LMMS, ни в ноутбуке вообще. У меня было только выход звука через наушники.

Звуковые уровни микшера ALSA находятся на максимальной мощности, это все, что я мог проверить.

Кто-нибудь испытал то же самое?

У меня возникла такая проблема с автоматической настройкой PulseAudio при загрузке.

Независимо от того, используете ли вы PulseAudio или любой другой звуковой сервер, я бы попытался изучить конфигурацию этого. Он часто отключает различные входы и выходы по какой-либо причине на разъеме / отключении, а пользовательский интерфейс не очень ясен (продолжает показывать изменения звука при отключении звука).

Это было так просто, как в прошлый раз, когда у меня была проблема.

Звуковые уровни микшера ALSA находятся на максимальной мощности, это все, что я мог проверить.

Не приглушены ли они? Приложение alsamixer показывает «MM» для приглушенных устройств и «оо» для немощных (в базе уровней). Запустите alsamixer с терминала, поскольку может быть ложное чтение через любые апплеты и т. Д.

Боковое замечание: я не использую PulseAudio именно по этой причине, что он делает странные вещи. Чистая ALSA не дает мне хлопот.

Линия «нет звука вообще» заставляет меня думать, что это может быть проблема с оборудованием.

В гнезде для наушников есть переключатель, который переключается между «динамиком» и наушниками. Если вы снова включите наушники, и они начнут работать, «переверните его» и снова отсоедините.

Конечно, если вы можете программно переключаться между «громкоговорителями» и наушниками без отсоединения наушников, это НЕ является проблемой аппаратного обеспечения.