Неудовлетворенные зависимости

Я пытаюсь скомпилировать vim и установить с флагом «–enable-pythoninterp», которому нужен пакет python-dev.

ИНФОРМАЦИЯ
Я получил источник vim от ftp://ftp.vim.org/pub/vim/unix/vim-7.3.tar.bz2
Vim7.3 пока недоступен, используя apt.
Использование Ubuntu 10.10

Но, sudo apt-get python-dev приводит к сообщению об ошибках пакетов ->

Следующие пакеты имеют неудовлетворенные зависимости:
python-dev: Зависит от python (= 2.6.6-2ubuntu1), но 2.6.6-2ubuntu2 должен быть установлен
E: Сломанные пакеты

Как я могу лучше всего решить эту проблему?


 $ apt-cache policy vim python python-dev 
 питон:
   Установлено: 2.6.6-2ubuntu2
   Кандидат: 2.6.6-2ubuntu2
   Таблица версий:
  *** 2.6.6-2ubuntu2 0
         100 / var / lib / dpkg / status
      2.6.6-2ubuntu1 0
         500 http://archive.ubuntu.com/ubuntu/ maverick / main i386 Пакеты
 ВИМ:
   Установлено: (нет)
   Кандидат: 2: 7.2.330-1ubuntu4
   Таблица версий:
      2: 7.2.330-1ubuntu4 0
         500 http://archive.ubuntu.com/ubuntu/ maverick / main i386 Пакеты
 питон-Dev:
   Установлено: (нет)
   Кандидат: 2.6.6-2ubuntu1
   Таблица версий:
      2.6.6-2ubuntu1 0
         500 http://archive.ubuntu.com/ubuntu/ maverick / main i386 Пакеты

3 Solutions collect form web for “Неудовлетворенные зависимости”

Это обычное сообщение apt производит, когда у вас есть пакеты, которые имеют разный приоритет. См. Man apt_preferences. python 2.6.6-2ubuntu1 не имеет достаточно высокого приоритета для установки, поэтому apt пытается установить 2.6.6-2ubuntu2, который не удовлетворяет зависимости. Для решения этой проблемы необходима дополнительная информация. Просьба представить результаты

 $ apt-cache policy vim python python-dev 

Также разместите свои файлы / etc / apt / preferences и /etc/apt/sources.list. Также дайте подробную информацию о том, как вы получили источник vim. Это источник восходящего потока? Вы загружали источник, используя источник apt-get или аналогичный? Если я правильно понял это, вы пытаетесь установить индивидуальную версию пакета vim. Это верно?

Основываясь на вашем выводе apt-cache policy , вам просто нужно понизить python с 2.6.6-2ubuntu2 до 2.6.6-2ubuntu1 . Как вы можете видеть, в настоящее время он не соответствует какой-либо версии в архивах. Вы знаете, откуда вы его взяли? Ну действуй

 $ apt-get install python=2.6.6-2ubuntu1 

а затем попробуйте

 $ sudo apt-get install python-dev 

еще раз.

Похоже, ваше обновление получило пакеты между загрузками пакетов: http://packages.ubuntu.com/maverick-updates/python-dev обе версии должны быть 2.6.6-2ubuntu2. Я бы попробовал:

 apt-get update 

и затем повторите попытку

 apt-get update apt-get install python python-dev 

Если это не сработает, я бы попытался переключиться на другое зеркало ubuntu, чтобы получить пакеты оттуда.

Если вы еще этого не сделали, попробуйте изменить ссылку на репозиторий пакета на «Главная» или в Соединенные Штаты . Выполнение этой задачи устранило мою проблему с неудовлетворенными зависимостями Python-dev (моя установка 12.04 использовала репозиторий пакетов United Kingdom, ранее).

  1. В «Ubuntu Software Center» (USC) перейдите в меню / вкладку «Редактировать => Источники программного обеспечения».
  2. Измените раскрывающееся значение «Загрузить с» на «Основной сервер» или на сервер в Соединенных Штатах.
  3. Оставьте USC, открыть «Менеджер обновлений» из меню программы Ubuntu и «Проверить» обновление программного обеспечения (или выпустить «sudo apt-get update» в окне терминала).
  4. Обновляйте программное обеспечение, как обычно, например, через «Update Manager» или apt-get / aptitude в терминале.

Это отремонтировало мой репозиторий, и я продолжал устанавливать все, что мне нужно после, как обычно.

Прежде чем исправить мою проблему с помощью вышеуказанных инструкций, различные команды aptitude / apt-get предложили удалить многие, многие пакеты, но, как вы можете оценить, я не хотел потерять свои 6-месячные + дополнения пакета, и это несмотря на то, что Я время от времени снимаю список пакетов (см. Мой текст для подсказок)! Я очень рад, что узнал о инструкциях, которые я оставляю здесь.

Надеюсь это поможет.

  • Как заставить VIM отображать 256 цветов правильно
  • Установите разрешения по умолчанию по типу файла (по крайней мере, в Vim)
  • Как я могу потянуть переменную env в отображение ключей VIM?
  • Где vim после установки pkg?
  • Почему соляризованная цветовая схема в vim выглядит иначе, чем в iTerm2?
  • у vi есть ошибка, которая изменяет пробелы в неотредактированных строках или есть возможность отключить эту функцию?
  • Обратные глобальные и локальные метки в vi / vim
  • Невозможно вставить команду в vim 8.0
  • Кадровое расширение для исходного кода в Vim
  • Удалите все файлы отмены Vim во всех, кроме одного каталога
  • Редактирование блока * live * в Emacs или Vim
  • Interesting Posts

    Какое из следующего использования якоря является правильным в регулярном выражении с помощью grep?

    Как поменять интегрированную графическую карту Intel на диск AMD

    Несоответствие команды lsof при попытке получить количество открытых файлов на каждый процесс

    Почему Bash не удалось найти команду, даже если $ PATH указан правильно?

    Можно ли загружать две библиотеки общих ресурсов приложения во время выполнения?

    sed – удаление нуля – / 08 / to / 8 /

    Устройство видеозахвата: любой шанс получить исходные данные?

    Предотвратить странные символы сеанса «Экран»

    Получить родительское устройство блока

    Как показать процессы, которые используют более 30% процессора?

    Двойной графический процессор – монитор, подключенный к интегрированной графике, показывает черный экран

    Настройте автозаполнение для первого аргумента, оставьте остальных в покое

    Сделайте строки в Libreoffice, которые выделяются после нажатия

    Как установить псевдоним для определенного файла или каталога?

    Не обнаружено устройство Ethernet

    Linux и Unix - лучшая ОС в мире.