Не удалось добавить репозиторий PPA из терминала

Я пытаюсь установить ap-hotspot на Ubuntu-14.04

Когда я вхожу в команду:

 sudo add-apt-repository ppa:nilarimogard/webupd8 

Это дает мне это сообщение

«Невозможно добавить PPA:« ppa »nilarimogard / webupd8« Пожалуйста, проверьте правильность имени и формата PPA »

Как я могу продолжить?

Поскольку я пользуюсь прокси-сервером для доступа в Интернет, поэтому я попробовал

 sudo -E add-apt-repository ppa:nilarimogard/webupd8 

но это не помогло. Но я могу запустить

 sudo apt-get update 

поэтому нет проблем с подключением к Интернету. Я также попытался переустановить ca-cerficates, используя команду

 sudo apt-get install --reinstall ca-certificates 

это также не решило проблему. Я также пробовал из Ubuntu Software Center, но там я также не могу добавить репозиторий PPA.

помогите мне в решении этой проблемы …

2 Solutions collect form web for “Не удалось добавить репозиторий PPA из терминала”

Поскольку вы не можете добавить репозиторий, вы всегда можете добавить их с терминала с помощью командной строки. Перейдите к списку репозиториев на веб-сайте WebUpd8 . Скопируйте адрес главного репозитория, который является основным хранилищем. Вы хотите добавить это, потому что он содержит все остальные.

  1. sudo cp /etc/apt/sources.list /etc/apt/sources.list.backup
  2. sudo gedit /etc/apt/sources.list
  3. Посетите Мастер-репозиторий в веб-браузере.
  4. Найдите стрелку раскрывающегося списка, которая гласит:

Техническая информация об этом PPA

  • Нажмите «Версия Ubuntu» в списке, отмеченном вами. Выберите свою версию
  • Добавьте полученный результат в файл на шаге 2.
  • Сохранить файл
  • sudo apt-get update . Теперь эта команда обновления должна получить приватные ключи нового репозитория. Если вы получили сообщение об ошибке, указанное в своем комментарии, то этот репозиторий не имеет закрытого ключа. Возможно, вам захочется связаться с разработчиком PPA в тот момент, кто либо предоставит вам ключ, либо попросит вас игнорировать предупреждение.
  • Я столкнулся с этой проблемой при установке Oracle JDK на машине Ubuntu 16.04.После нескольких поисков я нашел решение, которое действительно сработало. Нам просто нужно добавить свойства программного обеспечения, а затем мы можем установить Oracle JDK на нашу Linux-машину. Следуйте инструкциям ниже.

     Step-1 Open terminal Ctrl + Alt + T Step-2 sudo apt-get install software-properties-common Step-3 sudo add-apt-repository ppa:webupd8team/java Step-4 sudo apt-get update Step-5 sudo apt-get install oracle-java8-installer 

    В этом пакете будет установлен установщик для Oracle JDK 8 , который является текущей стабильной версией. Вы также можете заменить java8 в имени пакета java7 или java9 для установки разных версий, хотя эти версии не рекомендуются для разработки.

    Убедитесь, что Java и компилятор Java установлены правильно:

     Step-6 java -version or javac -version 

    Надеюсь, это поможет.

  • Как узнать, когда я установил пакет FOO
  • Вымытые цвета с помощью программного обеспечения screencast, но не скриншот на Ubuntu (все версии)
  • почему я вижу ошибку «stdin: is not tty» при использовании x2go для удаленного подключения к нескольким дистрибутивам Linux Linux?
  • Как изменить thisName @ HostName ~ $
  • Создайте Wifi Hotspot для совместного использования прокси SOCKS на сервере Ubuntu
  • Повернуть IPv6 для команд curl?
  • Менеджер окон для телевизора
  • Проблема с запуском Ubuntu на crouton после обновления chromeos
  • Как переключиться с CLI на GUI Ubuntu
  • Как узнать, есть ли я в тюрьме, контейнере, снимке и т. Д. Окружении?
  • Перемещено / bin содержимое в / usr / bin, можно отменить?
  • Interesting Posts
    Linux и Unix - лучшая ОС в мире.