Выполнить файл с определенной версией PHP

Мне нужно выполнить PHP-файл с другой версией PHP, установленной. Я знаю полный путь к другим версиям, но я не знаю, как его использовать.

Я прочитал справочную страницу PHP, но об этом не упоминается. Я предполагаю, что мне нужно сначала установить версию, а затем запустить ее.

Я знаю, как это сделать через htaccess , но не существует способа установить версию непосредственно в командной строке?

  • Запуск стеклянной рыбы на сервере LINUX удаленно
  • Запуск сценария bash с php от cron
  • Как установить phpmyadmin 4.0 на Debian
  • Загрузка Apache PHP - права собственности и разрешения
  • Диск ввода / вывода и средний пик нагрузки один раз в час
  • Не удалось запустить php на Linux Mint 17.1
  • PHP exec и amixer
  • Downprade PHP 5.4 -> 5.3 на CentOS 5.10
  • One Solution collect form web for “Выполнить файл с определенной версией PHP”

    Если вы хотите запустить php-скрипт в командной строке, вы должны использовать shebang, указывающий на абсолютный путь. Шебанг – первая строка в скрипте, в котором говорится о оболочке, которую программа должна использовать для ее выполнения:

     #!/path/to/your/alternative/php 

    затем сделайте свой скрипт исполняемым и просто запустите его:

     chmod +x yourscript.php ./yourscript.php 

    Или вы просто вызываете это напрямую с двоичной версией вашей альтернативной php-версии:

     /path/to/your/alternative/php yourscript.php 
    Linux и Unix - лучшая ОС в мире.