Не удалось загрузить модуль ядра 'nvidia.ko'

В моей системе я не могу установить рекомендуемый графический драйвер, поэтому что-то не так с моей установкой.

Чипсет GPU – ATI ES1000, но рекомендуемым драйвером является NVIDIA NVS300, загруженный с сайта поставщика сервера.

Максимальное графическое разрешение встроенного графического контроллера ATI ES1000 с собственным драйвером Microsoft Windows 2012 составляет 1280 x 1024. ATI не планирует поддерживать графический чип ATI ES1000 с Windows 2012. Таким образом, нет доступных OEM-драйверов, которые могут быть установлены на PRIMERGY TX100 S3 или TX100 S3p с Microsoft Windows 2012. Для более высоких графических разрешений на PRIMERGY TX100 S3 или TX100 S3p можно использовать графический контроллер PCIe NVIDIA® Quadro® NVS 300.

Перед установкой я переключился на уровень запуска 3 ( init 3 ) и черный список нуворишей ( echo blacklist nouveau > /etc/modprobe.d/nvidia.conf ). Ни один из конфликтующих драйверов не присутствует:

 # lsmod | grep -e nouveau -e rivafb -e nvidiafb (empty) 

Это все шаги, которые должны быть необходимы, что еще может быть неправильно в моем Linux Linux (на базе Red Hat Enterprise Linux 6.7, Kernel Linux 3.8.13-118.2.1.el6uek.x86_64, GNOME 2.28.2), я думал несовместимое ядро ​​или конфликт некоторых драйверов графического процессора?

Список ОС, поддерживаемый драйвером:

 Red Hat Enterprise Linux 6.6 (x86_64) Red Hat Enterprise Linux 6.7 (x86_64) Red Hat Enterprise Linux 7 GA (x86_64) Red Hat Enterprise Linux 7.1 (x86_64) SUSE Linux Enterprise Server 11 SP3 (x86_64) SUSE Linux Enterprise Server 11 SP4 (x86_64) 

Основная ошибка:

ОШИБКА: Не удается загрузить модуль ядра «nvidia.ko». Это происходит чаще всего, когда этот модуль ядра был создан против неправильных или неправильно сконфигурированных источников ядра, причем версия gcc отличается от версии, используемой для сборки целевого ядра, или если присутствует драйвер, такой как rivafb, nvidiafb или nouveau и не позволяет ядерному модулю NVIDIA получить право собственности на графические устройства NVIDIA, или NVIDIA GPU, установленный в этой системе, поддерживается этой версией графического драйвера NVIDIA Linux.

Вывод из /var/log/nvidia-installer.log :

 -> Kernel module compilation complete. -> Unable to determine if Secure Boot is enabled: No such file or directory ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release. Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information. -> Kernel module load error: insmod: error inserting './kernel/nvidia.ko': -1 No such device -> Kernel messages: survey done event(5c) band:0 for wlan0 ==>rtw_ps_processor .fw_state(8) ==>ips_enter cnts:5 ===> rtw_ips_pwr_down................... ====> rtw_ips_dev_unload... usb_read_port_cancel usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1) usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1) usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1) usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1) usb_write_port_cancel ==> rtl8192cu_hal_deinit bkeepfwalive(0) card disble without HWSM........... <=== rtw_ips_pwr_down..................... in 29ms usb 2-1.2: USB disconnect, device number 7 usb 2-1.2: new low-speed USB device number 8 using ehci-pci usb 2-1.2: New USB device found, idVendor=093a, idProduct=2510 usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0 usb 2-1.2: Product: USB Optical Mouse usb 2-1.2: Manufacturer: PixArt input: PixArt USB Optical Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input7 hid-generic 0003:093A:2510.0005: input,hidraw1: USB HID v1.11 Mouse [PixArt USB Optical Mouse] on usb-0000:00:1d.0-1.2/input0 NVRM: No NVIDIA graphics adapter found! NVRM: NVIDIA init module failed! ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com. 

2 Solutions collect form web for “Не удалось загрузить модуль ядра 'nvidia.ko'”

ES1000 встроен в вашу материнскую плату, NVS300 является дополнительным дополнительным. Вот почему вы получаете сообщение об ошибке: NVRM: No NVIDIA graphics adapter found!

В тексте, который вы цитируете, говорится, что если вы хотите иметь более высокое разрешение, чем то, что поддерживает ATI ES1000, вы можете установить Nvidia NVS300, который является совершенно другой и отдельной графической картой.

NVS300 также довольно старая карта. вы могли бы установить любую другую новейшую карту AMD или Nvidia, которая физически вписалась бы в слот (потребуется слот pci-e x16) и в корпус (вам может понадобиться небольшая безвентиляторная карта).

например, Nvidia GTX-750 (около 110 долларов США) полностью вытирает пол NVS300, это намного быстрее, чем это невозможно, и 750 даже не приближается к современному графическому процессору высшего класса. Даже гораздо более дешевые карты, такие как ~ $ 40USD GT610, значительно быстрее, чем NVS300.

Согласно http://www.fujitsu.com/tw/Images/ds-py-tx100-s3-en.pdf, ваша система имеет 1 слот pci-e 3.0, физически x16 (поэтому он может принимать полноразмерный x16 GPU карты), но только x8 в электронном виде, поэтому карта будет работать нормально, но со слегка уменьшенной пропускной способностью (графические процессоры в любом случае не будут использовать нигде вблизи полной полосы пропускания pci-e 3.0 @ x16).

Наконец, если вы просто хотите, чтобы встроенный графический процессор ES1000 работал, он должен просто работать с достаточно современным ядром Linux и X. Однако не ожидайте высокой разрешающей способности или быстрой графики.

Ваш ответ написан в журнале:

 No NVIDIA graphics adapter found! NVRM: NVIDIA init module failed! 

Вы не можете загрузить драйвер nvidia, если у вас нет карты NVIDIA на вашем компьютере.

Основное сообщение об ошибке, которое вы отметили о создании модуля ядра, является общим. Он не применяется в вашем случае, когда сообщение об ошибке становится ясным.

  • Внедрение сервера внезапно
  • По умолчанию оболочка в Oracle Linux?
  • Невозможно изменить размер файловой системы на многолучевом устройстве
  • Папка с d ?????????? в ls -l
  • Файл сценария Bash ping для проверки доступности хоста
  • Установщик Oracle Server не позволяет ввести значение в поле
  • Ограничение доступа только к командам CVS и Git
  • перенести все логические тома (включая swap и /) на новый диск
  • Oracle Linux 6.5: невозможно установить VLC 2.0.10 из rpmfusion-free-updates
  • Ошибка undefined ошибки Mkfs: ext2fs_numeric_progress_ops
  • Почему BROADCAST необходимо указать в файле ifcfg
  • Interesting Posts

    Почему я не могу подключить «/» внутри пространства имен пользователя?

    В чем разница между ключом сообщения и дескриптором сообщения при передаче сообщений в System V IPC?

    Создание новой виртуальной машины SLES 12 на XenServer 6.5 не выполняется

    Определить файлы text / ascii в Linux / Solaris

    Загрузка Linux на Mac с внутренним графическим процессором

    Ошибка Kino: ПРЕДУПРЕЖДЕНИЕ: модуль ядра dv1394 не загружен или отсутствует чтение / запись / dev / raw1394 на Fedora 20, dvgrab works

    / init не может найти / bin / mount, но найти / может?

    Соответствие специальных символов регулярному выражению

    человек дает ошибку о локали

    Двойная установка загрузки не имеет эффекта (без GRUB), Boot-Repair не помогает

    «Кеш и супер-поколение не совпадают, кеш-память будет недействительной», что это значит и как ее восстановить?

    Apache не может разблокировать: не может выделить память

    Pxeboot: клиент не получает IP-адрес от DHCP-сервера

    Узкие символы

    Фильтр geoip logstash не работает в Debian

    Linux и Unix - лучшая ОС в мире.