Обновление и установка пакета невозможны: E: Не удается найти пакет! Linux Mint 17.3

У меня проблема.

Установка пакетов или обновление системы невозможны.

Ни терминал, ни менеджер программного обеспечения не работают (Software Manager не запускается).

Терминал показывает команды следующим образом:

sudo apt-get update E: Type 'non-free' is not known on line 3 in source list /etc/apt/sources.list E: The list of sources could not be read. 

Когда я пытаюсь установить программу:

 sudo apt-get install exfat-utils exfat-fuse Reading package lists... Done Building dependency tree Reading state information... Done Package exfat-utils is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'exfat-utils' has no installation candidate E: Unable to locate package exfat-fuse sudo apt-get update && sudo apt-get install autokey-gtk E: Type 'non-free' is not known on line 3 in source list /etc/apt/sources.list E: The list of sources could not be read. sudo apt-get install autokey-gtk Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package autokey-gtk 

Содержимое файла списка моих источников выглядит следующим образом:

 #deb cdrom:[Linux Mint 17.3 _Rosa_ - Release amd64 20151128]/ trusty contrib main non-free deb http://xnv4.xandros.com/xs2.0/upkg-srv2 etch main contrib non-free deb http://xnv4.xandros.com/xs2.0/upkg-srv2 etch main contrib non-free 

Эта проблема возникла на моем предыдущем Linux Mint (17.0) и повторилась через несколько недель после установки LM 17.3.

Большое спасибо за вашу помощь, я ценю!

  • Можно ли установить определенную версию пакетов, от которых зависит основной пакет?
  • RHEL reposync, интерфейс управления?
  • Как объединить зависимости deb в основной пакет?
  • Из терминала ... не удается удалить пакет Python (не удалось найти), также не может установить (уже выполнено)
  • Как узнать, какой пакет содержит исполняемый файл?
  • Следующие пакеты имеют неудовлетворенные зависимости
  • Разница между установкой и установкой в ​​dpkg.log
  • dpkg - как установить предварительную зависимость?
  • One Solution collect form web for “Обновление и установка пакета невозможны: E: Не удается найти пакет! Linux Mint 17.3”

    Неверный формат sources.list . «non-free» не должен отображаться на отдельной строке. Вот почему вы видите:

     E: Type 'non-free' is not known on line 3 in source list /etc/apt/sources.list 

    Источники.list должны выглядеть следующим образом:

     #deb cdrom:[Linux Mint 17.3 _Rosa_ - Release amd64 20151128]/ trusty main contrib non-free deb http://xnv4.xandros.com/xs2.0/upkg-srv2 etch main contrib non-free deb http://xnv4.xandros.com/xs2.0/upkg-srv2 etch main contrib non-free 

    Также обратите внимание, что ваша первая строка закомментирована, поэтому у вас фактически есть только две строки, ни одна из которых не выглядит как стандартные источники для Mint. Вероятно, вы захотите добавить больше источников. Также подумайте, хотите ли вы сохранить источники xnv4.xandros.com .

    Linux и Unix - лучшая ОС в мире.