не может устанавливать гостевые дополнения virtuabbox или даже обновлять kali linux

Я загрузил kali linux из osboxes kali linux, потому что у меня возникли проблемы с установкой любой версии linux с использованием virtualbox на моем ноутбуке Windows. Я попытался установить гостевые дополнения virtualbox таким образом [UPDATE:] Сначала я запускаю apt-get update, но ничего не обновляю

apt-get install linux-headers-$(uname -r) -y 

но результат

 Unable to locate package linux-headers-4.3.0-kali-amd64 Couldnt find any package by glob 'linux-headers-4.3.0-kali-amd64' Couldnt find any package by regex'linux-headers-4.3.0-kali-amd64' 

Я попытался обновить параметры терминала и настройки, но сообщил, что все обновления установлены и новых обновлений нет

Я пытался

 apt -y install open-vm-tools-desktop fuse 

В результате

 Unable to locate package open-vm-tools-desktop 

Я пытался

 sudo apt-get -y dist-upgrade 

Результат

 0 upgraded 0 newly installed 0 to remove 0 not upgraded 

Я новичок в том, что linux просто запускает kali на virtualbox для изучения CEH, но не может обновлять или устанавливать пакеты. Итак, как это исправить?

[UPDATE] Я добавил репозитории и смог обновить kali, затем в терминале:

 apt -y install open-vm-tools-desktop fuse 

В результате «инструменты для плавких предохранителей и vm установлены и уже имеют новейшую версию», но до сих пор не могут найти общую папку из окон (как я могу в Parrot)) и по-прежнему не могут перетаскивать файлы

Вы проверили, какое репо у вас есть в файле /etc/apt/sources.list? Если вы только что установили Kali, вам может потребоваться заменить репозитории cd-rom стандартными репозиториями:

deb http://repo.kali.org/kali kali main non-free contrib

Так же как:

deb http://ftp.cc.uoc.gr/mirrors/linux/kali/kali-security/ kali / updates main contrib non-free

Проблема с apt-get install или apt-get upgrade будет исправлена ​​с помощью apt-get update . Это необходимо выполнить перед первой попыткой установки пакетов или в качестве первого шага в любом обновлении пакета. Конечно, это может просто показать вам более конкретную ошибку.

Обновление через графический интерфейс «Настройки», вероятно, использует PackageKit. В вашей системе он действует как интерфейс для apt-get . Я сожалею, что PackageKit может быть трудно понять и устранить неполадки. Я думаю, что у вас есть правильный подход при попытке устранить неполадку с помощью определенных команд apt-get в терминале, во-первых.

Например, PackageKit имеет командную строку, эквивалентную apt-get update . Во-первых, вам нужно знать правильные параметры, чтобы решить проблему вроде этого: pkcon refresh force или pkcon -c 1 refresh . Во-вторых, если не удается связаться с репозиториями, он может отображать только те репозиции (на Debian) или вообще ничего (Fedora IIRC, или если он считает, что компьютер не имеет сетевого подключения). Команда pkcon не имеет тенденций перечислять более конкретные ошибки. Теоретически PackageKit разработан для обновления ноутбуков, которые могут иметь или не иметь доступ в Интернет в данный момент времени. На практике он не справляется с сетевыми прерываниями; попытка исправить это была представлена ​​некоторое время назад, но требует пересмотра и на нее совсем не ответили. https://bugzilla.redhat.com/show_bug.cgi?id=1314991

добавлены основные репозитории в etc / apt / sources.list

 sudo apt-get -y dist-upgrade reboot 

затем выполнил следующие шаги: https://youtu.be/MkaJ3Nssxac?t=5m49s