Intereting Posts
Сценарий оболочки для переименования файлов Centos 6.5 не может войти в систему с открытым ключом и войти в систему sloooooow Порядок вывода с заменой процесса Порядок сигналов: SIGPOLL и SIGCHLD Firewalld: как белый список только двух IP-адресов, а не в одной подсети Как вырезать все до определенного слова / после поиска в скрипте Как запускать команды при входе пользователя в систему, которые еще не запущены Расписание (Cron), выполняющее задачи на основе сценариев bash с использованием CronniX Скопируйте строку в файл, если мы знаем шаблон Как захватить вывод mplayer в файл? Есть ли альтернатива с открытым исходным кодом для безопасной загрузки UEFI? Binding Shift-Enter для вставки новой строки без оценки текущего выражения Выберите имя файла с наивысшим номером версии Системная отправка SIGTERM и SIGKILL при нормальной работе Linux HID-драйвер для клавиатуры, отправляющий 1 дополнительный байт

поврежденные зависимости при установке Codelite 8 на linux mint

Я хочу установить код, я выполнил инструкции на веб-сайте.

Поскольку я использую linux mint 17.1 x64, я добавил репозитории для ubuntu utopic, надежной и яркой вселенной.

Теперь, когда я запускаю apt install codelite wxcrafter я получаю:
codelite: зависит: libglib2.0-0 (> = 2.41.1), но вместо этого устанавливается 2.40.2 – 0ubuntu1

  depends: libhunspell-1.3-0 (>= 1.3.3)but 1.3.2-6ubuntu2 is installed instead depends: liblldb-3.4 but is not installable depends: libstdc++6 (>= 4.9) but 4.8.2-19ubuntu1 is installed instead suggests: nodejs but is not going to be installed 

Я попробовал ответить на этот вопрос, но приведенные ссылки нарушены.

Я думаю, что проблема в том, что некоторые зависимости являются либо новыми для моего монетного двора (aka libglib2), либо несколько старыми (aka liblldb).

Я вижу liblldb-3.5 с apt-cache search , установка которого не удаляла строку «зависит: liblldb-3.4».

Я пробовал искать libglib2.0-0, я нашел версию 2.44 на странице debian и загрузил ее, установив ее, разбил мою систему, и мне пришлось отформатировать мой жесткий диск.

Итак, что делать, чтобы установить кошелёк 8 на linux mint 17,1 64-битный коричный?

Для монетного двора 17.1 используйте http://repos.codelite.org/ubuntu/ trusty universe

Что касается этапов,

  1. Удалите все другие коделиновые репозитории из /etc/apt/sources.list.d/additional-repositories.list.
  2. Добавьте правильное репо: sudo apt-add-repository 'deb http://repos.codelite.org/ubuntu/ trusty universe'
  3. Источники обновлений: обновление sudo apt-get
  4. Установка коделита: sudo apt-get install codelite

Это должно правильно установить все зависимости и кодовое имя.