Как указать требование для минимальной версии openssl в файле спецификации RPM?

Файл спецификации rpm для моего пакета выглядит так:

Requires:mysql-server >= 5.5.30, java >= 1.6, p7zip, openssl >= 1.0.2g 

У меня есть система RHEL, в которой версия openssl такова:

 [ag@rhel1]# openssl OpenSSL> version OpenSSL 1.0.1e-fips 11 Feb 2013 [ag@rhel1]# rpm -q --whatprovides openssl openssl-1.0.1e-51.el7_2.4.x86_64 

Когда я пытаюсь проверить установку моего пакета RPM, он должен выйти из строя, потому что мой пакет требует минимум 1.0.2g, тогда как 1.0.1e установлен. Однако установка успешно завершена без каких-либо проблем. Что мне здесь не хватает?

  • Получение «cpio: Плохая магия» при попытке установить rpm в установленный логический том
  • Извлечение исходных RPM в debian
  • Строить RPM, чтобы вести себя по-другому при установке и обновлении?
  • rpm -Uvh - Как заменить измененный файл конфигурации
  • Centos 7 - Не удается загрузить RPM (попытка подключения к IPV6)
  • Не удалось избавиться от репо на Centos 7
  • Как найти зависимости, требуемые пакетами RPM
  • Что такое пакеты gpg-pubkey *?
  • One Solution collect form web for “Как указать требование для минимальной версии openssl в файле спецификации RPM?”

    Afaik сравнение должно работать …

    Как вы устанавливаете rpm? Например, вы используете yum localinstall или rpm ?

    Можете ли вы проверить, есть ли у вас rpm правильные требования? (Использование rpm -qip --requires YourPackage.rpm )

    Вы можете проверить, как rpm сравнивает версию с rpmdevtools :

     # yum -y install rpmdevtools # rpmdev-vercmp openssl-1.0.1e-51.el7_2.4.x86_64 openssl-1.0.2g openssl-1.0.1e-51.el7_2.4.x86_64 < openssl-1.0.2g 

    PS. -whatprovides показывает только, какой пакет на вашей системе предоставляет возможность openssl . Если вы хотите узнать, что именно установлен установленный пакет, вам нужно запустить rpm -q --provides openssl-1.0.1e-51.el7_2.4.x86_64

    Linux и Unix - лучшая ОС в мире.