«Ошибка при загрузке разделяемых библиотек: libgtk-x11-2.0.so.0: невозможно открыть файл общих объектов» при выполнении двоичного кода oald8

Я установил oald8 на Linux 64-bit, на Debian.

Сначала я установил:

 apt-get install lib32z1 lib32ncurses5 dpkg-dev 

Затем перейдите к oald8 и запустите:

 linux32 ./setup.sh 

Я настроюсь успешно ….

Теперь мне нужно установить libglib1.2ldbl и libgtk1.2 , но, к сожалению, они устарели.

Когда я запускаю oal8 , я получаю следующую ошибку:

 ./oald8-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory 

Выше ошибка связана с данными пакетами.

На i386 я не испытывал никаких проблем.

Кстати, я следил за этой документацией.

У вас есть решение?

    Вам не хватает хотя бы одной (возможно, более) зависимостей от вашей системы. например, для libgtk-x11-2.0.so.0 вам необходимо установить пакет libgtk2.0-0 .

    Чтобы узнать, какие пакеты в вашем выпуске предоставляют данный файл, используйте поиск в нижней части https://packages.debian.org .

    Однако, похоже, вы пытаетесь установить 32-битный двоичный код на 64-битной системе. вам может потребоваться включить поддержку нескольких i386 архитектуры i386 и убедиться, что пакеты зависимостей, которые вы устанавливаете, предназначены для правильной арки.