Различные программы, не работающие после yum, устанавливают некоторые пакеты

[RESOLVED] Я узнал, что чип памяти вызвал проблемы. Я изменил его, и теперь система работает нормально!


Я использую RHEL6.0 и столкнулся с проблемой, что gdb, yum, rpm больше не работают. Возможно, проблемы с пакетами вызвали проблему.

# lsb_release -a LSB Version: :base-4.0-ia32:base-4.0-noarch:core-4.0-ia32:core-4.0-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-ia32:printing-4.0-noarch Distributor ID: RedHatEnterpriseServer Description: Red Hat Enterprise Linux Server release 6.0 (Santiago) Release: 6.0 Codename: Santiago # uname -a Linux electronics.server 2.6.32-431.11.2.el6.i686 #1 SMP Tue Mar 25 17:17:46 UTC 2014 i686 i686 i386 GNU/Linux 

Запуск gdb либо возвращает ошибку, либо аварийно падает:

 #gdb gdb: symbol lookup error: /usr/lib/libpython2.6.so.1.0: undefined symbol: yCodec_Lookup 

yum также терпит неудачу:

 #yum There was a problem importing one of the Python modules required to run yum. The error leading to this problem was: /usr/lib/python2.6/site-packages/rpm/_rpmmodule.so: undefined symbol: headerKsEntry Please install a package which provides this module, or verify that the module is installed correctly. It's possible that the above module doesn't match the current version of Python, which is: 2.6.6 (r266:84292, Jan 22 2014, 09:37:14) [GCC 4.4.7 20120313 (Red Hat 4.4.7-4)] If you cannot solve this problem yourself, please go to the yum faq at: http://yum.baseurl.org/wiki/Faq Segmentation fault (core dumped) 

Я использовал rpm для проверки:

 # rpm -V python yum error: rpmdb: damaged header #759 retrieved -- skipping. error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package python is not installed error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1107 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD Unsatisfied dependencies for yum-3.2.29-43.el6.centos.noarch: /usr/bin/python is needed by yum-3.2.29-43.el6.centos.noarch python >= 2.4 is needed by yum-3.2.29-43.el6.centos.noarch python(abi) = 2.6 is needed by yum-3.2.29-43.el6.centos.noarch python-sqlite is needed by yum-3.2.29-43.el6.centos.noarch ..5...... /usr/lib/python2.6/site-packages/rpmUtils/miscutils.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/oldUtils.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/oldUtils.pyo ..5...... /usr/lib/python2.6/site-packages/rpmUtils/updates.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/updates.pyo ..5...... /usr/lib/python2.6/site-packages/yum/__init__.py ..5...... /usr/lib/python2.6/site-packages/yum/__init__.pyc ..5...... /usr/lib/python2.6/site-packages/yum/misc.pyo ..5...... /usr/lib/python2.6/site-packages/yum/packageSack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/packageSack.pyo ..5...... /usr/lib/python2.6/site-packages/yum/packages.py ..5...... /usr/lib/python2.6/site-packages/yum/packages.pyo ..5...... /usr/lib/python2.6/site-packages/yum/parser.py ..5...... /usr/lib/python2.6/site-packages/yum/plugins.pyc ..5...... /usr/lib/python2.6/site-packages/yum/plugins.pyo ..5...... /usr/lib/python2.6/site-packages/yum/repoMDObject.pyc ..5...... /usr/lib/python2.6/site-packages/yum/repoMDObject.pyo ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.py ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.pyo ..5...... /usr/lib/python2.6/site-packages/yum/sqlitesack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/update_md.pyc ..5...... /usr/lib/python2.6/site-packages/yum/update_md.pyo ..5...... /usr/lib/python2.6/site-packages/yum/yumRepo.pyc ..5...... /usr/lib/python2.6/site-packages/yum/yumRepo.pyo ..5...... d /usr/share/doc/yum-3.2.29/COPYING ..5...... d /usr/share/doc/yum-3.2.29/ChangeLog ..5...... /usr/share/locale/es/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/fr/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/ja/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/pa/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/ru/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/sr/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/sr@latin/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/uk/LC_MESSAGES/yum.mo ..5...... /usr/share/yum-cli/callback.py ..5...... /usr/share/yum-cli/cli.py ..5...... /usr/share/yum-cli/cli.pyo ..5...... /usr/share/yum-cli/output.py ..5...... /usr/share/yum-cli/utils.pyc ..5...... /usr/share/yum-cli/utils.pyo ..5...... /usr/share/yum-cli/yumcommands.pyc ..5...... /usr/share/yum-cli/yumcommands.pyo # rpm -V rpm rpm-python error: rpmdbNextIterator: skipping h# 1306 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package rpm is not installed error: rpmdbNextIterator: skipping h# 1307 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package rpm-python is not installed *** glibc detected *** rpm: free(): invalid pointer: 0x09118fea *** ======= Backtrace: ========= /lib/libc.so.6[0x3bfe31] /lib/libnspr4.so(PR_Free+0x28)[0x2feee98] /lib/libplds4.so[0x318a6b] /lib/libplds4.so(PL_HashTableDestroy+0x67)[0x3181e7] /usr/lib/libnssutil3.so(SECOID_Shutdown+0x26)[0x2fc7046] /usr/lib/libnss3.so[0x302f3b1] /usr/lib/libnss3.so(NSS_Shutdown+0x85)[0x302f5f5] /usr/lib/librpmio.so.1(rpmFreeCrypto+0x24)[0x76d4d4] /usr/lib/librpm.so.1(rpmFreeRpmrc+0x3b9)[0x160379] rpm[0x8049e31] /lib/libc.so.6(__libc_start_main+0xe6)[0x365d26] rpm[0x8049531] ======= Memory map: ======== 0011d000-00181000 r-xp 00000000 fd:00 533150 /usr/lib/librpm.so.1.0.0 00181000-00185000 rw-p 00064000 fd:00 533150 /usr/lib/librpm.so.1.0.0 00185000-00186000 rw-p 00000000 00:00 0 00186000-00192000 r-xp 00000000 fd:00 2491287 /lib/libnss_files-2.12.so 00192000-00193000 r--p 0000b000 fd:00 2491287 /lib/libnss_files-2.12.so 00193000-00194000 rw-p 0000c000 fd:00 2491287 /lib/libnss_files-2.12.so 00194000-001d5000 r-xp 00000000 fd:00 532562 /usr/lib/libsoftokn3.so 001d5000-001d6000 r--p 00040000 fd:00 532562 /usr/lib/libsoftokn3.so 001d6000-001d7000 rw-p 00041000 fd:00 532562 /usr/lib/libsoftokn3.so 00317000-0031a000 r-xp 00000000 fd:00 2491739 /lib/libplds4.so 0031a000-0031b000 r--p 00002000 fd:00 2491739 /lib/libplds4.so 0031b000-0031c000 rw-p 00003000 fd:00 2491739 /lib/libplds4.so 0031e000-00322000 r-xp 00000000 fd:00 2491738 /lib/libplc4.so 00322000-00323000 r--p 00003000 fd:00 2491738 /lib/libplc4.so 00323000-00324000 rw-p 00004000 fd:00 2491738 /lib/libplc4.so 00329000-00347000 r-xp 00000000 fd:00 2491272 /lib/ld-2.12.so 00347000-00348000 r--p 0001d000 fd:00 2491272 /lib/ld-2.12.so 00348000-00349000 rw-p 0001e000 fd:00 2491272 /lib/ld-2.12.so 0034f000-004e0000 r-xp 00000000 fd:00 2491286 /lib/libc-2.12.so 004e0000-004e2000 r--p 00191000 fd:00 2491286 /lib/libc-2.12.so 004e2000-004e3000 rw-p 00193000 fd:00 2491286 /lib/libc-2.12.so 004e3000-004e6000 rw-p 00000000 00:00 0 004e8000-004eb000 r-xp 00000000 fd:00 2491500 /lib/libdl-2.12.so 004eb000-004ec000 r--p 00002000 fd:00 2491500 /lib/libdl-2.12.so 004ec000-004ed000 rw-p 00003000 fd:00 2491500 /lib/libdl-2.12.so 004ef000-00506000 r-xp 00000000 fd:00 2491341 /lib/libpthread-2.12.so 00506000-00507000 r--p 00016000 fd:00 2491341 /lib/libpthread-2.12.so 00507000-00508000 rw-p 00017000 fd:00 2491341 /lib/libpthread-2.12.so 00508000-0050a000 rw-p 00000000 00:00 0 0050c000-00513000 r-xp 00000000 fd:00 2491352 /lib/librt-2.12.so 00513000-00514000 r--p 00006000 fd:00 2491352 /lib/librt-2.12.so 00514000-00515000 rw-p 00007000 fd:00 2491352 /lib/librt-2.12.so 00517000-00529000 r-xp 00000000 fd:00 2491502 /lib/libz.so.1.2.3 00529000-0052a000 r--p 00011000 fd:00 2491502 /lib/libz.so.1.2.3 0052a000-0052b000 rw-p 00012000 fd:00 2491502 /lib/libz.so.1.2.3 0052d000-00555000 r-xp 00000000 fd:00 2491288 /lib/libm-2.12.so 00555000-00556000 r--p 00027000 fd:00 2491288 /lib/libm-2.12.so 00556000-00557000 rw-p 00028000 fd:00 2491288 /lib/libm-2.12.so 00559000-00574000 r-xp 00000000 fd:00 542113 /usr/lib/libmagic.so.1.0.0 00574000-00575000 rw-p 0001b000 fd:00 542113 /usr/lib/libmagic.so.1.0.0 00575000-00577000 rw-p 00000000 00:00 0 00579000-0059c000 r-xp 00000000 fd:00 530543 /usr/lib/librpmbuild.so.1.0.0 0059c000-0059e000 rw-p 00023000 fd:00 530543 /usr/lib/librpmbuild.so.1.0.0 0059e000-005a2000 rw-p 00000000 00:00 0 00667000-00684000 r-xp 00000000 fd:00 2491515 /lib/libselinux.so.1 00684000-00685000 r--p 0001c000 fd:00 2491515 /lib/libselinux.so.1 00685000-00686000 rw-p 0001d000 fd:00 2491515 /lib/libselinux.so.1 00688000-0069d000 r-xp 00000000 fd:00 2491513 /lib/libresolv-2.12.so 0069d000-0069e000 ---p 00015000 fd:00 2491513 /lib/libresolv-2.12.so 0069e000-0069f000 r--p 00015000 fd:00 2491513 /lib/libresolv-2.12.so 0069f000-006a0000 rw-p 00016000 fd:00 2491513 /lib/libresolv-2.12.so 006a0000-006a2000 rw-p 00000000 00:00 0 006a4000-006ba000 r-xp 00000000 fd:00 539294 /usr/lib/libelf-0.152.so 006ba000-006bb000 r--p 00015000 fd:00 539294 /usr/lib/libelf-0.152.so 006bb000-006bc000 rw-p 00016000 fd:00 539294 /usr/lib/libelf-0.152.so 006be000-006ea000 r-xp 00000000 fd:00 542941 /usr/lib/liblua-5.1.so 006ea000-006eb000 rw-p 0002c000 fd:00 542941 /usr/lib/liblua-5.1.so 00729000-0072a000 r-xp 00000000 00:00 0 [vdso] 00758000-00780000 r-xp 00000000 fd:00 539241 /usr/lib/librpmio.so.1.0.0 00780000-00782000 rw-p 00028000 fd:00 539241 /usr/lib/librpmio.so.1.0.0 00782000-00784000 rw-p 00000000 00:00 0 007b5000-007b8000 r-xp 00000000 fd:00 2494002 /lib/libcap.so.2.16 007b8000-007b9000 rw-p 00002000 fd:00 2494002 /lib/libcap.so.2.16 00909000-0090e000 r-xp 00000000 fd:00 2491285 /lib/libnss_dns-2.12.so 0090e000-0090f000 r--p 00004000 fd:00 2491285 /lib/libnss_dns-2.12.so 0090f000-00910000 rw-p 00005000 fd:00 2491285 /lib/libnss_dns-2.12.so 009b6000-00a10000 r-xp 00000000 fd:00 2491524 /lib/libfreebl3.so 00a10000-00a11000 r--p 00059000 fd:00 2491524 /lib/libfreebl3.so 00a11000-00a12000 rw-p 0005a000 fd:00 2491524 /lib/libfreebl3.so 00a12000-00a16000 rw-p 00000000 00:00 0 00dea000-00df1000 r-xp 00000000 fd:00 2493999 /lib/libacl.so.1.1.0 00df1000-00df2000 r--p 00006000 fd:00 2493999 /lib/libacl.so.1.1.0 00df2000-00df3000 rw-p 00007000 fd:00 2493999 /lib/libacl.so.1.1.0 02bdb000-02bfe000 r-xp 00000000 fd:00 535421 /usr/lib/liblzma.so.0.0.0 02bfe000-02bff000 rw-p 00022000 fd:00 535421 /usr/lib/liblzma.so.0.0.0 02dfc000-02e19000 r-xp 00000000 fd:00 2491333 /lib/libgcc_s-4.4.7-20120601.so.1 02e19000-02e1a000 rw-p 0001d000 fd:00 2491333 /lib/libgcc_s-4.4.7-20120601.so.1 02e70000-02efe000 r-xp 00000000 fd:00 531021 /usr/lib/libsqlite3.so.0.8.6 02efe000-02f00000 rw-p 0008d000 fd:00 531021 /usr/lib/libsqlite3.so.0.8.6 02fb6000-02fd7000 r-xp 00000000 fd:00 530325 /usr/lib/libnssutil3.so 02fd7000-02fda000 r--p 00021000 fd:00 530325 /usr/lib/libnssutil3.so 02fda000-02fdb000 rw-p 00024000 fd:00 530325 /usr/lib/libnssutil3.so 02fdd000-03017000 r-xp 00000000 fd:00 2491734 /lib/libnspr4.so 03017000-03018000 r--p 00039000 fd:00 2491734 /lib/libnspr4.so 03018000-03019000 rw-p 0003a000 fd:00 2491734 /lib/libnspr4.so 03019000-0301b000 rw-p 00000000 00:00 0 0301d000-03154000 r-xp 00000000 fd:00 530395 /usr/lib/libnss3.so 03154000-03157000 r--p 00136000 fd:00 530395 /usr/lib/libnss3.so 03157000-03159000 rw-p 00139000 fd:00 530395 /usr/lib/libnss3.soAborted (core dumped) в # rpm -V python yum error: rpmdb: damaged header #759 retrieved -- skipping. error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package python is not installed error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1107 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD Unsatisfied dependencies for yum-3.2.29-43.el6.centos.noarch: /usr/bin/python is needed by yum-3.2.29-43.el6.centos.noarch python >= 2.4 is needed by yum-3.2.29-43.el6.centos.noarch python(abi) = 2.6 is needed by yum-3.2.29-43.el6.centos.noarch python-sqlite is needed by yum-3.2.29-43.el6.centos.noarch ..5...... /usr/lib/python2.6/site-packages/rpmUtils/miscutils.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/oldUtils.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/oldUtils.pyo ..5...... /usr/lib/python2.6/site-packages/rpmUtils/updates.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/updates.pyo ..5...... /usr/lib/python2.6/site-packages/yum/__init__.py ..5...... /usr/lib/python2.6/site-packages/yum/__init__.pyc ..5...... /usr/lib/python2.6/site-packages/yum/misc.pyo ..5...... /usr/lib/python2.6/site-packages/yum/packageSack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/packageSack.pyo ..5...... /usr/lib/python2.6/site-packages/yum/packages.py ..5...... /usr/lib/python2.6/site-packages/yum/packages.pyo ..5...... /usr/lib/python2.6/site-packages/yum/parser.py ..5...... /usr/lib/python2.6/site-packages/yum/plugins.pyc ..5...... /usr/lib/python2.6/site-packages/yum/plugins.pyo ..5...... /usr/lib/python2.6/site-packages/yum/repoMDObject.pyc ..5...... /usr/lib/python2.6/site-packages/yum/repoMDObject.pyo ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.py ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.pyo ..5...... /usr/lib/python2.6/site-packages/yum/sqlitesack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/update_md.pyc ..5...... /usr/lib/python2.6/site-packages/yum/update_md.pyo ..5...... /usr/lib/python2.6/site-packages/yum/yumRepo.pyc ..5...... /usr/lib/python2.6/site-packages/yum/yumRepo.pyo ..5...... d /usr/share/doc/yum-3.2.29/COPYING ..5...... d /usr/share/doc/yum-3.2.29/ChangeLog ..5...... /usr/share/locale/es/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/fr/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/ja/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/pa/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/ru/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/sr/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/sr@latin/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/uk/LC_MESSAGES/yum.mo ..5...... /usr/share/yum-cli/callback.py ..5...... /usr/share/yum-cli/cli.py ..5...... /usr/share/yum-cli/cli.pyo ..5...... /usr/share/yum-cli/output.py ..5...... /usr/share/yum-cli/utils.pyc ..5...... /usr/share/yum-cli/utils.pyo ..5...... /usr/share/yum-cli/yumcommands.pyc ..5...... /usr/share/yum-cli/yumcommands.pyo # rpm -V rpm rpm-python error: rpmdbNextIterator: skipping h# 1306 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package rpm is not installed error: rpmdbNextIterator: skipping h# 1307 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package rpm-python is not installed *** glibc detected *** rpm: free(): invalid pointer: 0x09118fea *** ======= Backtrace: ========= /lib/libc.so.6[0x3bfe31] /lib/libnspr4.so(PR_Free+0x28)[0x2feee98] /lib/libplds4.so[0x318a6b] /lib/libplds4.so(PL_HashTableDestroy+0x67)[0x3181e7] /usr/lib/libnssutil3.so(SECOID_Shutdown+0x26)[0x2fc7046] /usr/lib/libnss3.so[0x302f3b1] /usr/lib/libnss3.so(NSS_Shutdown+0x85)[0x302f5f5] /usr/lib/librpmio.so.1(rpmFreeCrypto+0x24)[0x76d4d4] /usr/lib/librpm.so.1(rpmFreeRpmrc+0x3b9)[0x160379] rpm[0x8049e31] /lib/libc.so.6(__libc_start_main+0xe6)[0x365d26] rpm[0x8049531] ======= Memory map: ======== 0011d000-00181000 r-xp 00000000 fd:00 533150 /usr/lib/librpm.so.1.0.0 00181000-00185000 rw-p 00064000 fd:00 533150 /usr/lib/librpm.so.1.0.0 00185000-00186000 rw-p 00000000 00:00 0 00186000-00192000 r-xp 00000000 fd:00 2491287 /lib/libnss_files-2.12.so 00192000-00193000 r--p 0000b000 fd:00 2491287 /lib/libnss_files-2.12.so 00193000-00194000 rw-p 0000c000 fd:00 2491287 /lib/libnss_files-2.12.so 00194000-001d5000 r-xp 00000000 fd:00 532562 /usr/lib/libsoftokn3.so 001d5000-001d6000 r--p 00040000 fd:00 532562 /usr/lib/libsoftokn3.so 001d6000-001d7000 rw-p 00041000 fd:00 532562 /usr/lib/libsoftokn3.so 00317000-0031a000 r-xp 00000000 fd:00 2491739 /lib/libplds4.so 0031a000-0031b000 r--p 00002000 fd:00 2491739 /lib/libplds4.so 0031b000-0031c000 rw-p 00003000 fd:00 2491739 /lib/libplds4.so 0031e000-00322000 r-xp 00000000 fd:00 2491738 /lib/libplc4.so 00322000-00323000 r--p 00003000 fd:00 2491738 /lib/libplc4.so 00323000-00324000 rw-p 00004000 fd:00 2491738 /lib/libplc4.so 00329000-00347000 r-xp 00000000 fd:00 2491272 /lib/ld-2.12.so 00347000-00348000 r--p 0001d000 fd:00 2491272 /lib/ld-2.12.so 00348000-00349000 rw-p 0001e000 fd:00 2491272 /lib/ld-2.12.so 0034f000-004e0000 r-xp 00000000 fd:00 2491286 /lib/libc-2.12.so 004e0000-004e2000 r--p 00191000 fd:00 2491286 /lib/libc-2.12.so 004e2000-004e3000 rw-p 00193000 fd:00 2491286 /lib/libc-2.12.so 004e3000-004e6000 rw-p 00000000 00:00 0 004e8000-004eb000 r-xp 00000000 fd:00 2491500 /lib/libdl-2.12.so 004eb000-004ec000 r--p 00002000 fd:00 2491500 /lib/libdl-2.12.so 004ec000-004ed000 rw-p 00003000 fd:00 2491500 /lib/libdl-2.12.so 004ef000-00506000 r-xp 00000000 fd:00 2491341 /lib/libpthread-2.12.so 00506000-00507000 r--p 00016000 fd:00 2491341 /lib/libpthread-2.12.so 00507000-00508000 rw-p 00017000 fd:00 2491341 /lib/libpthread-2.12.so 00508000-0050a000 rw-p 00000000 00:00 0 0050c000-00513000 r-xp 00000000 fd:00 2491352 /lib/librt-2.12.so 00513000-00514000 r--p 00006000 fd:00 2491352 /lib/librt-2.12.so 00514000-00515000 rw-p 00007000 fd:00 2491352 /lib/librt-2.12.so 00517000-00529000 r-xp 00000000 fd:00 2491502 /lib/libz.so.1.2.3 00529000-0052a000 r--p 00011000 fd:00 2491502 /lib/libz.so.1.2.3 0052a000-0052b000 rw-p 00012000 fd:00 2491502 /lib/libz.so.1.2.3 0052d000-00555000 r-xp 00000000 fd:00 2491288 /lib/libm-2.12.so 00555000-00556000 r--p 00027000 fd:00 2491288 /lib/libm-2.12.so 00556000-00557000 rw-p 00028000 fd:00 2491288 /lib/libm-2.12.so 00559000-00574000 r-xp 00000000 fd:00 542113 /usr/lib/libmagic.so.1.0.0 00574000-00575000 rw-p 0001b000 fd:00 542113 /usr/lib/libmagic.so.1.0.0 00575000-00577000 rw-p 00000000 00:00 0 00579000-0059c000 r-xp 00000000 fd:00 530543 /usr/lib/librpmbuild.so.1.0.0 0059c000-0059e000 rw-p 00023000 fd:00 530543 /usr/lib/librpmbuild.so.1.0.0 0059e000-005a2000 rw-p 00000000 00:00 0 00667000-00684000 r-xp 00000000 fd:00 2491515 /lib/libselinux.so.1 00684000-00685000 r--p 0001c000 fd:00 2491515 /lib/libselinux.so.1 00685000-00686000 rw-p 0001d000 fd:00 2491515 /lib/libselinux.so.1 00688000-0069d000 r-xp 00000000 fd:00 2491513 /lib/libresolv-2.12.so 0069d000-0069e000 ---p 00015000 fd:00 2491513 /lib/libresolv-2.12.so 0069e000-0069f000 r--p 00015000 fd:00 2491513 /lib/libresolv-2.12.so 0069f000-006a0000 rw-p 00016000 fd:00 2491513 /lib/libresolv-2.12.so 006a0000-006a2000 rw-p 00000000 00:00 0 006a4000-006ba000 r-xp 00000000 fd:00 539294 /usr/lib/libelf-0.152.so 006ba000-006bb000 r--p 00015000 fd:00 539294 /usr/lib/libelf-0.152.so 006bb000-006bc000 rw-p 00016000 fd:00 539294 /usr/lib/libelf-0.152.so 006be000-006ea000 r-xp 00000000 fd:00 542941 /usr/lib/liblua-5.1.so 006ea000-006eb000 rw-p 0002c000 fd:00 542941 /usr/lib/liblua-5.1.so 00729000-0072a000 r-xp 00000000 00:00 0 [vdso] 00758000-00780000 r-xp 00000000 fd:00 539241 /usr/lib/librpmio.so.1.0.0 00780000-00782000 rw-p 00028000 fd:00 539241 /usr/lib/librpmio.so.1.0.0 00782000-00784000 rw-p 00000000 00:00 0 007b5000-007b8000 r-xp 00000000 fd:00 2494002 /lib/libcap.so.2.16 007b8000-007b9000 rw-p 00002000 fd:00 2494002 /lib/libcap.so.2.16 00909000-0090e000 r-xp 00000000 fd:00 2491285 /lib/libnss_dns-2.12.so 0090e000-0090f000 r--p 00004000 fd:00 2491285 /lib/libnss_dns-2.12.so 0090f000-00910000 rw-p 00005000 fd:00 2491285 /lib/libnss_dns-2.12.so 009b6000-00a10000 r-xp 00000000 fd:00 2491524 /lib/libfreebl3.so 00a10000-00a11000 r--p 00059000 fd:00 2491524 /lib/libfreebl3.so 00a11000-00a12000 rw-p 0005a000 fd:00 2491524 /lib/libfreebl3.so 00a12000-00a16000 rw-p 00000000 00:00 0 00dea000-00df1000 r-xp 00000000 fd:00 2493999 /lib/libacl.so.1.1.0 00df1000-00df2000 r--p 00006000 fd:00 2493999 /lib/libacl.so.1.1.0 00df2000-00df3000 rw-p 00007000 fd:00 2493999 /lib/libacl.so.1.1.0 02bdb000-02bfe000 r-xp 00000000 fd:00 535421 /usr/lib/liblzma.so.0.0.0 02bfe000-02bff000 rw-p 00022000 fd:00 535421 /usr/lib/liblzma.so.0.0.0 02dfc000-02e19000 r-xp 00000000 fd:00 2491333 /lib/libgcc_s-4.4.7-20120601.so.1 02e19000-02e1a000 rw-p 0001d000 fd:00 2491333 /lib/libgcc_s-4.4.7-20120601.so.1 02e70000-02efe000 r-xp 00000000 fd:00 531021 /usr/lib/libsqlite3.so.0.8.6 02efe000-02f00000 rw-p 0008d000 fd:00 531021 /usr/lib/libsqlite3.so.0.8.6 02fb6000-02fd7000 r-xp 00000000 fd:00 530325 /usr/lib/libnssutil3.so 02fd7000-02fda000 r--p 00021000 fd:00 530325 /usr/lib/libnssutil3.so 02fda000-02fdb000 rw-p 00024000 fd:00 530325 /usr/lib/libnssutil3.so 02fdd000-03017000 r-xp 00000000 fd:00 2491734 /lib/libnspr4.so 03017000-03018000 r--p 00039000 fd:00 2491734 /lib/libnspr4.so 03018000-03019000 rw-p 0003a000 fd:00 2491734 /lib/libnspr4.so 03019000-0301b000 rw-p 00000000 00:00 0 0301d000-03154000 r-xp 00000000 fd:00 530395 /usr/lib/libnss3.so 03154000-03157000 r--p 00136000 fd:00 530395 /usr/lib/libnss3.so 03157000-03159000 rw-p 00139000 fd:00 530395 /usr/lib/libnss3.soAborted (core dumped) в # rpm -V python yum error: rpmdb: damaged header #759 retrieved -- skipping. error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package python is not installed error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 764 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1107 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD Unsatisfied dependencies for yum-3.2.29-43.el6.centos.noarch: /usr/bin/python is needed by yum-3.2.29-43.el6.centos.noarch python >= 2.4 is needed by yum-3.2.29-43.el6.centos.noarch python(abi) = 2.6 is needed by yum-3.2.29-43.el6.centos.noarch python-sqlite is needed by yum-3.2.29-43.el6.centos.noarch ..5...... /usr/lib/python2.6/site-packages/rpmUtils/miscutils.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/oldUtils.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/oldUtils.pyo ..5...... /usr/lib/python2.6/site-packages/rpmUtils/updates.pyc ..5...... /usr/lib/python2.6/site-packages/rpmUtils/updates.pyo ..5...... /usr/lib/python2.6/site-packages/yum/__init__.py ..5...... /usr/lib/python2.6/site-packages/yum/__init__.pyc ..5...... /usr/lib/python2.6/site-packages/yum/misc.pyo ..5...... /usr/lib/python2.6/site-packages/yum/packageSack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/packageSack.pyo ..5...... /usr/lib/python2.6/site-packages/yum/packages.py ..5...... /usr/lib/python2.6/site-packages/yum/packages.pyo ..5...... /usr/lib/python2.6/site-packages/yum/parser.py ..5...... /usr/lib/python2.6/site-packages/yum/plugins.pyc ..5...... /usr/lib/python2.6/site-packages/yum/plugins.pyo ..5...... /usr/lib/python2.6/site-packages/yum/repoMDObject.pyc ..5...... /usr/lib/python2.6/site-packages/yum/repoMDObject.pyo ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.py ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/rpmsack.pyo ..5...... /usr/lib/python2.6/site-packages/yum/sqlitesack.pyc ..5...... /usr/lib/python2.6/site-packages/yum/update_md.pyc ..5...... /usr/lib/python2.6/site-packages/yum/update_md.pyo ..5...... /usr/lib/python2.6/site-packages/yum/yumRepo.pyc ..5...... /usr/lib/python2.6/site-packages/yum/yumRepo.pyo ..5...... d /usr/share/doc/yum-3.2.29/COPYING ..5...... d /usr/share/doc/yum-3.2.29/ChangeLog ..5...... /usr/share/locale/es/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/fr/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/ja/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/pa/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/ru/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/sr/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/sr@latin/LC_MESSAGES/yum.mo ..5...... /usr/share/locale/uk/LC_MESSAGES/yum.mo ..5...... /usr/share/yum-cli/callback.py ..5...... /usr/share/yum-cli/cli.py ..5...... /usr/share/yum-cli/cli.pyo ..5...... /usr/share/yum-cli/output.py ..5...... /usr/share/yum-cli/utils.pyc ..5...... /usr/share/yum-cli/utils.pyo ..5...... /usr/share/yum-cli/yumcommands.pyc ..5...... /usr/share/yum-cli/yumcommands.pyo # rpm -V rpm rpm-python error: rpmdbNextIterator: skipping h# 1306 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package rpm is not installed error: rpmdbNextIterator: skipping h# 1307 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD package rpm-python is not installed *** glibc detected *** rpm: free(): invalid pointer: 0x09118fea *** ======= Backtrace: ========= /lib/libc.so.6[0x3bfe31] /lib/libnspr4.so(PR_Free+0x28)[0x2feee98] /lib/libplds4.so[0x318a6b] /lib/libplds4.so(PL_HashTableDestroy+0x67)[0x3181e7] /usr/lib/libnssutil3.so(SECOID_Shutdown+0x26)[0x2fc7046] /usr/lib/libnss3.so[0x302f3b1] /usr/lib/libnss3.so(NSS_Shutdown+0x85)[0x302f5f5] /usr/lib/librpmio.so.1(rpmFreeCrypto+0x24)[0x76d4d4] /usr/lib/librpm.so.1(rpmFreeRpmrc+0x3b9)[0x160379] rpm[0x8049e31] /lib/libc.so.6(__libc_start_main+0xe6)[0x365d26] rpm[0x8049531] ======= Memory map: ======== 0011d000-00181000 r-xp 00000000 fd:00 533150 /usr/lib/librpm.so.1.0.0 00181000-00185000 rw-p 00064000 fd:00 533150 /usr/lib/librpm.so.1.0.0 00185000-00186000 rw-p 00000000 00:00 0 00186000-00192000 r-xp 00000000 fd:00 2491287 /lib/libnss_files-2.12.so 00192000-00193000 r--p 0000b000 fd:00 2491287 /lib/libnss_files-2.12.so 00193000-00194000 rw-p 0000c000 fd:00 2491287 /lib/libnss_files-2.12.so 00194000-001d5000 r-xp 00000000 fd:00 532562 /usr/lib/libsoftokn3.so 001d5000-001d6000 r--p 00040000 fd:00 532562 /usr/lib/libsoftokn3.so 001d6000-001d7000 rw-p 00041000 fd:00 532562 /usr/lib/libsoftokn3.so 00317000-0031a000 r-xp 00000000 fd:00 2491739 /lib/libplds4.so 0031a000-0031b000 r--p 00002000 fd:00 2491739 /lib/libplds4.so 0031b000-0031c000 rw-p 00003000 fd:00 2491739 /lib/libplds4.so 0031e000-00322000 r-xp 00000000 fd:00 2491738 /lib/libplc4.so 00322000-00323000 r--p 00003000 fd:00 2491738 /lib/libplc4.so 00323000-00324000 rw-p 00004000 fd:00 2491738 /lib/libplc4.so 00329000-00347000 r-xp 00000000 fd:00 2491272 /lib/ld-2.12.so 00347000-00348000 r--p 0001d000 fd:00 2491272 /lib/ld-2.12.so 00348000-00349000 rw-p 0001e000 fd:00 2491272 /lib/ld-2.12.so 0034f000-004e0000 r-xp 00000000 fd:00 2491286 /lib/libc-2.12.so 004e0000-004e2000 r--p 00191000 fd:00 2491286 /lib/libc-2.12.so 004e2000-004e3000 rw-p 00193000 fd:00 2491286 /lib/libc-2.12.so 004e3000-004e6000 rw-p 00000000 00:00 0 004e8000-004eb000 r-xp 00000000 fd:00 2491500 /lib/libdl-2.12.so 004eb000-004ec000 r--p 00002000 fd:00 2491500 /lib/libdl-2.12.so 004ec000-004ed000 rw-p 00003000 fd:00 2491500 /lib/libdl-2.12.so 004ef000-00506000 r-xp 00000000 fd:00 2491341 /lib/libpthread-2.12.so 00506000-00507000 r--p 00016000 fd:00 2491341 /lib/libpthread-2.12.so 00507000-00508000 rw-p 00017000 fd:00 2491341 /lib/libpthread-2.12.so 00508000-0050a000 rw-p 00000000 00:00 0 0050c000-00513000 r-xp 00000000 fd:00 2491352 /lib/librt-2.12.so 00513000-00514000 r--p 00006000 fd:00 2491352 /lib/librt-2.12.so 00514000-00515000 rw-p 00007000 fd:00 2491352 /lib/librt-2.12.so 00517000-00529000 r-xp 00000000 fd:00 2491502 /lib/libz.so.1.2.3 00529000-0052a000 r--p 00011000 fd:00 2491502 /lib/libz.so.1.2.3 0052a000-0052b000 rw-p 00012000 fd:00 2491502 /lib/libz.so.1.2.3 0052d000-00555000 r-xp 00000000 fd:00 2491288 /lib/libm-2.12.so 00555000-00556000 r--p 00027000 fd:00 2491288 /lib/libm-2.12.so 00556000-00557000 rw-p 00028000 fd:00 2491288 /lib/libm-2.12.so 00559000-00574000 r-xp 00000000 fd:00 542113 /usr/lib/libmagic.so.1.0.0 00574000-00575000 rw-p 0001b000 fd:00 542113 /usr/lib/libmagic.so.1.0.0 00575000-00577000 rw-p 00000000 00:00 0 00579000-0059c000 r-xp 00000000 fd:00 530543 /usr/lib/librpmbuild.so.1.0.0 0059c000-0059e000 rw-p 00023000 fd:00 530543 /usr/lib/librpmbuild.so.1.0.0 0059e000-005a2000 rw-p 00000000 00:00 0 00667000-00684000 r-xp 00000000 fd:00 2491515 /lib/libselinux.so.1 00684000-00685000 r--p 0001c000 fd:00 2491515 /lib/libselinux.so.1 00685000-00686000 rw-p 0001d000 fd:00 2491515 /lib/libselinux.so.1 00688000-0069d000 r-xp 00000000 fd:00 2491513 /lib/libresolv-2.12.so 0069d000-0069e000 ---p 00015000 fd:00 2491513 /lib/libresolv-2.12.so 0069e000-0069f000 r--p 00015000 fd:00 2491513 /lib/libresolv-2.12.so 0069f000-006a0000 rw-p 00016000 fd:00 2491513 /lib/libresolv-2.12.so 006a0000-006a2000 rw-p 00000000 00:00 0 006a4000-006ba000 r-xp 00000000 fd:00 539294 /usr/lib/libelf-0.152.so 006ba000-006bb000 r--p 00015000 fd:00 539294 /usr/lib/libelf-0.152.so 006bb000-006bc000 rw-p 00016000 fd:00 539294 /usr/lib/libelf-0.152.so 006be000-006ea000 r-xp 00000000 fd:00 542941 /usr/lib/liblua-5.1.so 006ea000-006eb000 rw-p 0002c000 fd:00 542941 /usr/lib/liblua-5.1.so 00729000-0072a000 r-xp 00000000 00:00 0 [vdso] 00758000-00780000 r-xp 00000000 fd:00 539241 /usr/lib/librpmio.so.1.0.0 00780000-00782000 rw-p 00028000 fd:00 539241 /usr/lib/librpmio.so.1.0.0 00782000-00784000 rw-p 00000000 00:00 0 007b5000-007b8000 r-xp 00000000 fd:00 2494002 /lib/libcap.so.2.16 007b8000-007b9000 rw-p 00002000 fd:00 2494002 /lib/libcap.so.2.16 00909000-0090e000 r-xp 00000000 fd:00 2491285 /lib/libnss_dns-2.12.so 0090e000-0090f000 r--p 00004000 fd:00 2491285 /lib/libnss_dns-2.12.so 0090f000-00910000 rw-p 00005000 fd:00 2491285 /lib/libnss_dns-2.12.so 009b6000-00a10000 r-xp 00000000 fd:00 2491524 /lib/libfreebl3.so 00a10000-00a11000 r--p 00059000 fd:00 2491524 /lib/libfreebl3.so 00a11000-00a12000 rw-p 0005a000 fd:00 2491524 /lib/libfreebl3.so 00a12000-00a16000 rw-p 00000000 00:00 0 00dea000-00df1000 r-xp 00000000 fd:00 2493999 /lib/libacl.so.1.1.0 00df1000-00df2000 r--p 00006000 fd:00 2493999 /lib/libacl.so.1.1.0 00df2000-00df3000 rw-p 00007000 fd:00 2493999 /lib/libacl.so.1.1.0 02bdb000-02bfe000 r-xp 00000000 fd:00 535421 /usr/lib/liblzma.so.0.0.0 02bfe000-02bff000 rw-p 00022000 fd:00 535421 /usr/lib/liblzma.so.0.0.0 02dfc000-02e19000 r-xp 00000000 fd:00 2491333 /lib/libgcc_s-4.4.7-20120601.so.1 02e19000-02e1a000 rw-p 0001d000 fd:00 2491333 /lib/libgcc_s-4.4.7-20120601.so.1 02e70000-02efe000 r-xp 00000000 fd:00 531021 /usr/lib/libsqlite3.so.0.8.6 02efe000-02f00000 rw-p 0008d000 fd:00 531021 /usr/lib/libsqlite3.so.0.8.6 02fb6000-02fd7000 r-xp 00000000 fd:00 530325 /usr/lib/libnssutil3.so 02fd7000-02fda000 r--p 00021000 fd:00 530325 /usr/lib/libnssutil3.so 02fda000-02fdb000 rw-p 00024000 fd:00 530325 /usr/lib/libnssutil3.so 02fdd000-03017000 r-xp 00000000 fd:00 2491734 /lib/libnspr4.so 03017000-03018000 r--p 00039000 fd:00 2491734 /lib/libnspr4.so 03018000-03019000 rw-p 0003a000 fd:00 2491734 /lib/libnspr4.so 03019000-0301b000 rw-p 00000000 00:00 0 0301d000-03154000 r-xp 00000000 fd:00 530395 /usr/lib/libnss3.so 03154000-03157000 r--p 00136000 fd:00 530395 /usr/lib/libnss3.so 03157000-03159000 rw-p 00139000 fd:00 530395 /usr/lib/libnss3.soAborted (core dumped) 

Любая помощь или совет будут очень признательны.

Обновить:

 # mv /var/lib/rpm /var/lib/rpm.bak # mkdir /var/lib/rpm # cp /var/lib/rpm.bak/Packages /var/lib/rpm/ # rpm --rebuilddb rpmdb: page 0: illegal page type or format rpmdb: PANIC: Invalid argument error: db3 error(-30974) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery error: error(-30974) getting "/usr/lib/" records from Dirnames index rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery error: error(-30974) getting "/usr/share/doc/" records from Dirnames index rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery error: error(-30974) getting "/usr/share/doc/libXau-1.0.6/" records from Dirnames index rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from dbcursor->c_close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->sync: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db_create: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Requireversion index using db3 - (-30974) rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db_create: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Provideversion index using db3 - (-30974) rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db_create: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Installtid index using db3 - (-30974) rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db_create: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Sigmd5 index using db3 - (-30974) rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db_create: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Sha1header index using db3 - (-30974) rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db_create: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Filedigests index using db3 - (-30974) error: cannot add record originally at 769 rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery rpmdb: File handles still open at environment close rpmdb: Open file handle: /var/lib/rpmrebuilddb.16120/Packages rpmdb: Open file handle: /var/lib/rpmrebuilddb.16120/Name rpmdb: Open file handle: /var/lib/rpmrebuilddb.16120/Basenames rpmdb: Open file handle: /var/lib/rpmrebuilddb.16120/Group rpmdb: Open file handle: /var/lib/rpmrebuilddb.16120/Requirename rpmdb: Open file handle: /var/lib/rpmrebuilddb.16120/Providename rpmdb: Open file handle: /var/lib/rpmrebuilddb.16120/Dirnames rpmdb: PANIC: fatal region error detected; run recovery error: db3 error(-30974) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery warning: failed to rebuild database: original database remains in place error: failed to remove directory /var/lib/rpmrebuilddb.16120: No such file or directory 

переустановить rpm-python и python не удается:

 # rpm -ivh --force rpm-python-4.8.0-37.el6.i686.rpm python-2.6.6-51.el6.i686.rpm error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1186 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 765 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 838 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1306 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 1156 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 765 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: rpmdbNextIterator: skipping h# 766 Header V3 RSA/SHA1 Signature, key ID c105b9de: BAD error: Failed dependencies: libc.so.6 is needed by rpm-python-4.8.0-37.el6.i686 libc.so.6(GLIBC_2.0) is needed by rpm-python-4.8.0-37.el6.i686 libc.so.6(GLIBC_2.1) is needed by rpm-python-4.8.0-37.el6.i686 libc.so.6(GLIBC_2.1.3) is needed by rpm-python-4.8.0-37.el6.i686 libc.so.6(GLIBC_2.3.4) is needed by rpm-python-4.8.0-37.el6.i686 libelf.so.1 is needed by rpm-python-4.8.0-37.el6.i686 libm.so.6 is needed by rpm-python-4.8.0-37.el6.i686 libpthread.so.0 is needed by rpm-python-4.8.0-37.el6.i686 libpthread.so.0(GLIBC_2.0) is needed by rpm-python-4.8.0-37.el6.i686 libpython2.6.so.1.0 is needed by rpm-python-4.8.0-37.el6.i686 librt.so.1 is needed by rpm-python-4.8.0-37.el6.i686 libselinux.so.1 is needed by rpm-python-4.8.0-37.el6.i686 rpm = 4.8.0-37.el6 is needed by rpm-python-4.8.0-37.el6.i686 rtld(GNU_HASH) is needed by rpm-python-4.8.0-37.el6.i686 libc.so.6 is needed by python-2.6.6-51.el6.i686 libc.so.6(GLIBC_2.0) is needed by python-2.6.6-51.el6.i686 libdl.so.2 is needed by python-2.6.6-51.el6.i686 libm.so.6 is needed by python-2.6.6-51.el6.i686 libpthread.so.0 is needed by python-2.6.6-51.el6.i686 libpython2.6.so.1.0 is needed by python-2.6.6-51.el6.i686 libutil.so.1 is needed by python-2.6.6-51.el6.i686 python-libs(x86-32) = 2.6.6-51.el6 is needed by python-2.6.6-51.el6.i686 rtld(GNU_HASH) is needed by python-2.6.6-51.el6.i686 

One Solution collect form web for “Различные программы, не работающие после yum, устанавливают некоторые пакеты”

Похоже, ваш rpmdb поврежден, rpm -V python говорит, что package python is not installed , но yum даже сообщает вам, какая у вас версия python.
Итак, сначала попробуйте перестроить ваш rpmdb:

 mv /var/lib/rpm /var/lib/rpm.bak mkdir /var/lib/rpm cp /var/lib/rpm.bak/packages /var/lib/rpm rpm --rebuilddb restorecon -r /var/lib/rpm 

затем перезапустите rpm -V python yum и запустите yum check .


Если ваш rpmdb не удалось перестроить, удалите /var/lib/rpm , переместите /var/lib/rpm.bak и запустите restorecon -vr /var/lib/rpm если вы получите некоторый вывод, запустите rm -f /var/lib/rpm/__* а затем повторный запуск rpm --rebuilddb


Если это тоже не удастся исправить, вручную скачайте rpm-python и python из rpm --rebuilddb и установите через rpm -i rpm-python python после этого снова попробуйте rpm --rebuilddb

  • RHEL 7 Масштабирование частоты процессора
  • рекомендуемое место хранения для нескольких пользователей
  • linux + yum + как напечатать переменные yum командой yum
  • Написание триггеров для mcelog
  • Почему я получаю сообщение об ошибке: «Не удалось открыть« / dev / st0 »при извлечении архива с помощью bsdtar?
  • как запустить новое программное обеспечение без обновления GLIBC?
  • Как автоматизировать подключение к нескольким сетевым устройствам, выполнить команду и сохранить вывод в файл?
  • Запустить скрипт на нескольких оболочках?
  • это скрипт, который запускается под текущей оболочкой или дочерней оболочкой?
  • Какова цель UUID для сетевых адаптеров?
  • Не удалось добавить eth0 в Rhel 7
  • Interesting Posts

    Получить список требуемых библиотек при установке чего-либо из источника

    Выполните условие IF из результата, который мы получаем с удаленного сервера

    Создание точной копии установки Windows

    Установите заголовки linux 4.12 на Kali 2017.2

    Как команда "pmount" работает без "sudo"

    Как я могу начать dwm с другого представления (т. Е. Другого тега)?

    Существует ли (предпочтительно не-kludgey) способ избежать орфографических исправлений при использовании команды zv `mv`

    проблема в зеркалировании трафика интерфейсов с использованием OVS

    Чтобы посчитать количество совпадений в мега-строке быстро

    Как я могу узнать, что определенный дистрибутив Linux основан на Debian, глядя на структуру файлов?

    Как я могу изменить все содержимое внутри каталога на то, что принадлежит файлу и разрешениям по умолчанию?

    Определите размер RAM-диска настраиваемого kali iso при загрузке в реальном времени

    Какие символы следует избегать при изменении файла с помощью sed?

    libvirt: команда запускать все гостевые виртуальные машины с включенным автозапуском

    Вам нужно перезапустить службы после запуска sysctl -p?

    Linux и Unix - лучшая ОС в мире.