Полная смена обновления системы Pacman

Я пытаюсь выполнить полное обновление системы с помощью pacman на ArchLinux. У меня есть ядро ​​3.2.

При вводе sudo pacman -Syu я получил следующие ошибки

 :: Synchronizing package databases... core is up to date extra is up to date community is up to date :: Starting full system upgrade... error: could not parse package description file 'libice-1.0.8-1/desc' from db 'extra' resolving dependencies... warning: cannot resolve "p11-kit>=0.12", a dependency of "gnutls" warning: cannot resolve "vim-runtime=7.3.495-1", a dependency of "gvim" :: The following packages cannot be upgraded due to unresolvable dependencies: gnutls gvim Do you want to skip the above packages for this upgrade? [y/N] y looking for inter-conflicts... error: failed to prepare transaction (could not satisfy dependencies) :: nvidia: requires linux<3.3 

Я попытался переустановить libice, но получил следующую ошибку

 error: could not parse package description file 'libice-1.0.8-1/desc' from db 'extra' warning: libice-1.0.8-1 is up to date -- reinstalling resolving dependencies... looking for inter-conflicts... error: failed to prepare transaction (package filename is not valid) 

Как я могу исправить эту проблему?

Я считаю, что вы используете зеркало, которое (путь) не синхронизировано.

Пакеты p11-kit , vim-runtime были обновлены в 2012-04-01 и 2012-04-10 соответственно. Пакет nvidia обновлен сегодня (2012-04-11), поэтому все, что вам нужно сделать, это подождать некоторое время.

Это довольно интересно, что у вас есть пакет linux версии 3.3, хотя и пакет gvim с 2012-04-10. Вы в последнее время меняли репозитории (отключенное testing ) или зеркала? Возможно, вы захотите использовать зеркальный или зеркальный фильтр для поиска актуального зеркала рядом с вами. Это, скорее всего, также восстановит ваш extra файл db.