Получение ошибки при попытке добавить репозиторий

Всякий раз, когда я пытаюсь добавить репозиторий, я получаю NoDistroTemplate Exception . Я использую Linux Mint 14 Nadia.

 tusharmakkar08@tusharmakkar08-Satellite-C660 ~ $ sudo add-apt-repository ppa:webupd8team/java You are about to add the following PPA to your system: Oracle Java (JDK) Installer (automatically downloads and installs Oracle JDK6 / JDK7 / JDK8). There are no actual Java files in this PPA. More info: http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html More info: https://launchpad.net/~webupd8team/+archive/java Press [ENTER] to continue or ctrl-c to cancel adding it Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 161, in <module> sp = SoftwareProperties(options=options) File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 104, in __init__ self.reload_sourceslist() File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 592, in reload_sourceslist self.distro.get_sources(self.sourceslist) File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 87, in get_sources raise NoDistroTemplateException("Error: could not find a " aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template 

Как удалить это исключение?

One Solution collect form web for “Получение ошибки при попытке добавить репозиторий”

Я думаю, что ошибка довольно понятна. PPA, который вы пытаетесь добавить, не предоставляет пакеты для вашей конкретной версии / выпуска Mint. По крайней мере, не на уровне PPA, хотя пакеты могут быть полностью совместимы.

Взгляните на это Q & A на askubuntu , в частности на этот ответ .

Существует решение, которое вы можете попробовать, но на самом деле это не рекомендуется для решения этой конкретной проблемы:

выдержка из этого сообщения на форуме :

Ошибка в шаблоне распространения относится к файлу «/ etc / lsb-release». Он должен читать что-то вроде …

 DISTRIB_ID=Ubuntu DISTRIB_RELEASE=11.10 DISTRIB_CODENAME=oneiric DISTRIB_DESCRIPTION="Ubuntu 11.10" 

Версия ubuntu зависит от версии используемого вами монетного двора. Вы должны иметь возможность изменить DISTRIB_DESCRIPTION, чтобы изменить имя ОС во время загрузки grub, но вы не можете изменить остальные, не нарушая шаблон распространения source.list.

  • Linux Mint: Hibernate не работает
  • Linux Mint 13 XFCE зависает при подключении внешнего монитора
  • могут ли пакеты, помеченные Debian / Ubuntu, быть установлены в Linux Mint?
  • Ошибка при попытке подключения к Интернету с использованием wvdial
  • Как включить прокрутку двумя пальцами без параметров трекпада?
  • resolvconf записывает недопустимый файл resolv.conf
  • LinuxMint15: приостановка работы ОЗУ не работает
  • Некоторые из моих приложений всегда запускаются при входе в Linux Mint
  • Проблема с установкой phpmyadmin
  • не удается установить libcups2-dev
  • Получение веб-безопасных шрифтов, работающих с LinuxMint
  • Мой раздел Linux не имеет стабильного подключения к Интернету
  • Linux и Unix - лучшая ОС в мире.