Как установить конкретную версию?

Как установить определенную версию Ansible, используя Yum или другой метод?

Когда я пытаюсь установить версию 2.0, он говорит, что нет пакета 2.0 .

Я проверил epel repo. Есть только два rpms, но без rpm, содержащих версию 2.0. Почему они удаляются? Есть ли способ установить определенную версию, например, 2.0?

  • Пытается обновить php на CentOS 5.7
  • YUM не разрешает зависимость с требованием для более старой версии
  • Как найти и установить указать пакет по команде?
  • Каким будет эквивалент «apt-cache show» на RHEL * без необходимости sudo / su?
  • YUM: Как запретить EPEL обновлять пакеты, установленные из других репозиториев?
  • Yum не может получить репозиторий CentOS 6
  • Ошибка «Не удается запустить скомпилированные программы» при установке модуля PDO PHP
  • Установка PHP 5.3.3-24 на CentOS 6.5 (Final)
  • One Solution collect form web for “Как установить конкретную версию?”

    Я бы порекомендовал pip :

     sudo pip install 'ansible==2.0.0.1' 

    Дополнительная информация о документации [1] и pip [2] .

    И если вы хотите иметь более одной установленной версии, просто используйте create virtualenv :

     virtualenv .env source .env/bin/activate pip install 'ansible==2.2.0.0' 

    и только этот терминал будет использовать эту конкретную версию Ansible. Затем повторите процесс для каждой комбинации, которую вы хотите.

    Linux и Unix - лучшая ОС в мире.