Монетный двор 12 – Ошибка обновления MySQL (mysql-client-core-5.1)

У меня MySQL 5.5 установлен через packages.dotdeb.org. При попытке обновления 5.1, который также установлен, появляется следующее сообщение об ошибке:

E: /var/cache/apt/archives/mysql-client-core-5.1_5.1.66-0ubuntu0.11.10.2_amd64.deb: пытается перезаписать '/usr/share/man/man1/mysqlcheck.1.gz', который также находится в пакете mysql-client-core-5.5 5.5.28-1 ~ dotdeb.0

Я не уверен, как действовать дальше. Я установил 5.1 перед тем, как узнать, как получить более свежие пакеты в менеджере обновлений / пакета Mint. Я не хочу сохранять 5.1, поскольку у меня есть 5.5, но я обеспокоен тем, что удаление его с помощью apt испортит мою установку 5.5. Можно ли безопасно удалить 5.1? Если нет, как мне следует продолжить?

Как бы то ни было, у вас установлен MySQL 5.5 … новичок, чем MySQL 5.1. Вероятно, это часть вашей проблемы. Если вы хотите заменить 5.5 на 5.1 (и понизить), сначала сначала следует удалить 5.5, а затем установить 5.1. Вы никогда не должны смешивать версии MySQL в локальной установке, не используя другой установочный префикс. Это может привести к проблемам с зависимостями (ссылка на неправильный код, загрузка неправильной библиотеки и т. Д.). [Или, может быть, я не совсем понимаю]