Как исправить эти нарушенные зависимости?

aptitude говорит мне, что у меня есть пакеты со сломанными зависимостями:

kmiller@debian-dev-box:~$ sudo aptitude search '.*' | grep ^.B iB console-setup-linux - Linux specific part of console-setup iB gir1.2-freedesktop - Introspection data for some FreeDesktop co iB gir1.2-glib-2.0 - Introspection data for GLib, GObject, Gio iB gir1.2-gstreamer-0.10 - Description: GObject introspection data fo iB gir1.2-json-1.0 - GLib JSON manipulation library (introspect iBA libatk-adaptor - AT-SPI 2 toolkit bridge iB libgcc1 - GCC support library iBA libgfortran3 - Runtime library for GNU Fortran applicatio iBA libgomp1 - GCC OpenMP (GOMP) support library iB libstdc++6 - GNU Standard C++ Library v3 

Но «сломанная» не может быть слишком плохой, потому что:

 kmiller@debian-dev-box:~$ sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. kmiller@debian-dev-box:~$ sudo apt-get -u dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

Самое тревожное, что libgcc1 нарушил зависимости.

Что мне делать, чтобы узнать, что исправить ?!

 kmiller@debian-dev-box:~$ sudo aptitude install -f ... 0 packages upgraded, 11 newly installed, 177 to remove and 0 not upgraded. ... The following packages have unmet dependencies: libstdc++6 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed. gir1.2-json-1.0 : Conflicts: gir1.0-json-glib-1.0 but 0.10.2-2squeeze1 is to be installed. gir1.2-gstreamer-0.10 : Conflicts: gir1.0-gstreamer-0.10 but 0.10.30-1 is to be installed. libgfortran3 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed. libgomp1 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed. libgcc1 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed. gir1.2-freedesktop : Conflicts: gir1.0-freedesktop but 0.6.14-1+b1 is to be installed. gir1.2-glib-2.0 : Conflicts: gir1.0-glib-2.0 but 0.6.14-1+b1 is to be installed. libatk-adaptor : Conflicts: at-spi but 1.32.0-2 is to be installed. console-setup-linux : Breaks: console-terminus but 4.30-2 is to be installed. 

  • Сделать пакет deb, который устанавливает данные в / var / www / data
  • Получение списка пакетов, установленных вручную по aptitude
  • Как удалить группу ненужных пакетов Debian?
  • Debian, нет X, нет Интернета, как скомпилировать драйвер беспроводной сети?
  • Несовместимые версии libsqlite3-0 (i386 и amd64) блокируют друг друга
  • Как свернуть apt source.list
  • Как я могу отменить эффекты обновления reprepro?
  • Что происходит, когда два apt-пакета зависят от двух разных версий одного и того же пакета?
  • One Solution collect form web for “Как исправить эти нарушенные зависимости?”

    apt-get и aptitude имеют разные зависимости. Вы можете получить aptitude, чтобы предлагать предложения по исправлению сломанных пакетов с помощью aptitude install -f . Судя по вашему обновленному вопросу, похоже, что у вас есть смешанные релизы или дистрибутивы в вашем sources.list .

    Interesting Posts
    Linux и Unix - лучшая ОС в мире.