Как установить обновления безопасности на debian

Из-за ошибки Shell Shock мне нужно делать обновления на некоторых наших машинах.
Но я не уверен, что все пакеты, предлагаемые в apt-get upgrade подходят для моей системы. Другими словами, я не уверен, есть ли какие-либо зависимости.

Наше системного администратора еще нет, и мы не можем связаться с ним.
Поэтому мой вопрос: как я могу только apt-get upgrade безопасности, только не обновляя все до новейшей доступной версии в debian stable?

РЕДАКТИРОВАТЬ РЕШЕНИЕ
apt-get install --only-upgrade bash сделал для меня все.
На одном из наших серверов был установлен только Debian Squeeze.
Меняя сжатие на wheezy в /etc/apt/sources.list а затем запускаем:
apt-get update
apt-get install --only-upgrade bash
установил фиксированный бит в эту более старую систему сжатия.

Для использования Squeeze используйте сжатие, если это возможно! (только i386 и amd64 …)

добавьте это в свой источник.list:

 deb http://http.debian.net/debian squeeze-lts main contrib non-free deb-src http://http.debian.net/debian squeeze-lts main contrib non-free 

а затем запустить

 apt-get update apt-get install -t squeeze-lts --only-upgrade bash 

Вот более подробная информация о squeeze-lts: https://wiki.debian.org/LTS/Using

Если вы действительно хотите исправить debian lenny, проверьте этот gist (но скорее рассмотрите обновление до более нового дистрибутива!)

Вы можете использовать:

 apt-get install --only-upgrade <package> 

Если установлено, это обновит только указанный пакет.

Ubuntu 12.04 «Точный» и 14.04 «Надежный», Debian 7 «Wheezy»

 apt-get update; apt-get install bash 

Debian 6 "Squeeze"

/etc/apt/sources.list.d/squeezelts.list

 deb http://http.debian.net/debian/ squeeze-lts main contrib non-free deb-src http://http.debian.net/debian/ squeeze-lts main contrib non-free 

/etc/apt/apt.conf.d/50squeezelts

 APT::Default-Release "squeeze-lts"; 

Затем запустите обновление:

 apt-get update; apt-get install bash 

Исправление старых и неподдерживаемых систем как Lenny

 # Retrieve and install dependencies first apt-get update && apt-get install build-essential gettext bison # Get bash 3.2 source wget http://ftp.gnu.org/gnu/bash/bash-3.2.tar.gz tar zxvf bash-3.2.tar.gz cd bash-3.2 # Download and apply all patches # Includes patches for CVE-2014-6271 (52) *AND* CVE-2014-7169 (53) *AND* Florian Weimer patch (54) for i in $(seq -f "%03g" 1 54); do wget -nv http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-$i patch -p0 < bash32-$i done # Compile and install to /usr/local/bin/bash ./configure && make make install # Point /bin/bash to the new binary mv /bin/bash /bin/bash.old ln -s /usr/local/bin/bash /bin/bash 

добавьте это в список источников:

deb http://ftp.de.debian.org/debian sid main

apt-get update apt-get install – только обновить bash