Ошибка: пакет ‘mongodb’ не имеет кандидата на установку

Я не могу apt-get установить какие-либо пакеты в облаке 9 для моего BeagleBone, потому что у E: Package 'mongodb' has no installation candidate . Я не смог заставить работать какие-либо пакеты из-за той же ошибки. Я обновил, обновил, перезагрузил, но ничего не получилось.

Больше информации о моем BBG:

 debian@beaglebone:/var/lib/cloud9$ uname -a Linux beaglebone 4.9.82-ti-r102 #1 SMP PREEMPT Thu Feb 22 01:16:12 UTC 2018 armv7l GNU/Linux debian@beaglebone:/var/lib/cloud9$ cat /etc/*-release PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" ID=debian HOME_URL="https://www.debian.org/" SUPPORT_URL="https://www.debian.org/support" BUG_REPORT_URL="https://bugs.debian.org/" 

Также, вот мой файл sources.list:

 GNU nano 2.7.4 File: /etc/apt/sources.list deb http://deb.debian.org/debian stretch main contrib non-free #deb-src http://deb.debian.org/debian stretch main contrib non-free deb http://deb.debian.org/debian stretch-updates main contrib non-free #deb-src http://deb.debian.org/debian stretch-updates main contrib non-free deb http://deb.debian.org/debian-security stretch/updates main contrib non-free #deb-src http://deb.debian.org/debian-security stretch/updates main contrib non-free #deb http://deb.debian.org/debian stretch-backports main contrib non-free ##deb-src http://deb.debian.org/debian stretch-backports main contrib non-free #Kernel source (repos.rcn-ee.com) : https://github.com/RobertCNelson/linux-stable-rcn-ee # #git clone https://github.com/RobertCNelson/linux-stable-rcn-ee #cd ./linux-stable-rcn-ee #git checkout `uname -r` -b tmp # deb [arch=armhf] http://repos.rcn-ee.com/debian/ stretch main #deb-src [arch=armhf] http://repos.rcn-ee.com/debian/ stretch main deb http://debian.mirror.ac.za/debian stretch main #deb-src http://debian.mirror.ac.za/debian stretch main 

MongoDB не поддерживается на armhf , архитектура, которую использует ваш BeagleBone; см. # 836435 для деталей. В результате он больше не доступен в репозиториях Debian для Debian 9 и новее.