Как я могу установить старые пакеты программных пакетов на CentOS 6?

У меня есть Dockerfile для сборки на Centos 6 с GCC 5.3, который выглядит так:

FROM centos:6 RUN yum -y update && yum -y install centos-release-scl RUN yum -y update && yum -y install devtoolset-4-gcc-c++ RUN scl enable devtoolset-4 ./build.sh #Build with gcc 5 

К сожалению, devtoolset-4 больше не поддерживается в centos-release-scl. Нетрудно найти зеркала, в которых все еще есть файл; например

http://mirror.centos.org/centos/6/sclo/x86_64/rh/devtoolset-4/devtoolset-4-gcc-c++-5.3.1-6.1.el6.x86_64.rpm

Но я не уверен, как установить из этого (или из локальной загрузки его). Любая помощь приветствуется.

NB. Я знаю, что не идеально использовать неподдерживаемые пакеты, но единственная альтернатива, которую я могу найти, – это создать GCC с нуля, что занимает так много времени, что время сборки моего dockerа в CI заканчивается.